10

At @Life's suggestion, I checked out this post. The solution was quite easy and worked like a charm (Thanks, @Life!). In the terminal, I typed sudo nano /etc/rc.local which opened that file in the nano text editor. Then, above the exit 0 line, I added rfkill block bluetooth, like so: After saving and exiting nano (Ctrl-X, Y, Enter), then restarting my ...


9

First of all, following steps are directly derived from answer by @wolf Note: This answer has only been tested on Ubuntu 16.04(Dropped here from google search. Thought to add my experience) And I am assuming that: a) you have already paired (say) 'QY7' bluetooth earphones with your Ubuntu. b) it is listed as 'QY7' in the System Settings -> (Hardware)...


4

Funnily enough, I found the answer while writing this post, so I might as well write my first-ever Q&A post on StackExchange. You have to go to Sound Settings and under the options for your Bluetooth headphones, switch the Mode to High Fidelity Playback (or whatever other option there is.)


4

maybe your bluetooth is soft blocked? try : sudo rfkill list if it is blocked, try this command sudo rfkill unblock bluetooth hope it helps!


4

I found an older post regarding this situation for Ubuntu 15.04 and a bug report that was filed for it. That can be found here: https://bugs.launchpad.net/ubuntu/+source/indicator-sound/+bug/1404729 I tried to duplicate your issue using a set of Bluetooth headphones but was unable to do so and do not have a wireless speaker to try out but I think the ...


3

It's a known bug. You can try installing 'sudo apt install switchboard-plug-bluetooth' It should add bluetooth setting to your system settings menu up to next system update. Moreover, I turn on my Bluetooth with 'bluetooth on' Command. Then I'm able to connect to devices from tray icon. However, Bluetooth right now is in a ruin and I hope so that it'...


3

I don't use bluetooth so I can't test, but I found something that should work: When your device is connected, it should be listed in /var/lib/bluetooth by its MAC address. In that MAC address folder should be a config file. Edit the line that starts with name to the name you'd like. Restart bluetooth: sudo service bluetooth restart I believe this would be ...


3

You can disable it by adding next line to /etc/rc.local file with following system restart: rfkill block bluetooth


3

There is an Ubuntu hardware compatibility list (https://certification.ubuntu.com/desktop/) though no Asus machines are in the list. That doesn't mean they aren't compatible by any means. It just means they haven't been tested by Ubuntu (elementary OS's base). Personally I've seen Dell machines work best with linux. I've never had any compatibility issues.


3

I have managed to fix this in elementaryOS 5 (Juno). You might be able to do this on lower versions as well: Pair the device with your computer using the default Bluetooth settings in the control panel (I assume that you have already done this). Install blueman: sudo apt-get install blueman Open blueman services: blueman-services A window should open, here ...


3

In addition to what Pieter shared in his answer, I had to take the following additional steps before I could receive files from a Windows 10 laptop: After installing blueman, restart the computer and open the applet (It might be possible to run the applet without restarting: blueman-applet). Click on the applet icon and select "Devices...". Select the ...


2

According to this site, HP Pavilion g7-2268wm does not have Bluetooth http://support.hp.com/us-en/document/c03487531 I even checked the Windows drivers for the machine and couldn't find anything. http://support.hp.com/us-en/drivers/selfservice/HP-Pavilion-g7-Notebook-PC-series/5296086/model/5312246 This post claims that you need Kernel 4.4.0 (Xenial) in ...


2

In terminal: Enter the /etc/bluetooth/main.conf file. There you'll find settings for bluetooth. I see that the last line is about AutoEnable, change it to true. :)


2

You can use a udev rule to disable a bluetooth controller. gksudo gedit /etc/udev/rules.d/81-bluetooth-hci.rules And paste the following in as one line SUBSYSTEM=="usb", ATTRS{idVendor}=="8087", ATTRS{idProduct}=="07dc", ATTR{authorized}="0" Save, exit program After a reboot the internal Intel bluetooth chip will not function


2

I remember seeing it in the system settings applet, but not anymore. Try installing this application sudo apt install bluman This is the standard ubuntu application Best of luck!


2

I would just use terminal to pair with the headset if the bluetooth manager is causing problems bluetoothctl scan on If the headset is in pairing mode it should show as a [NEW] Device followed by the MAC address and it's bluetooth name Then just do pair followed by the MAC address- use capital letters trust followed by the MAC and then use connect followed ...


2

Open /etc/bluetooth/main.conf and change AutoEnable=true to AutoEnable=false.


2

I have to resize my Bluetooth window (Device search) for it to show an actual list of devices it sees. Heres to hoping the answer is just that simple.


2

From what I understand you are looking to set up a PAN. Ubuntu is preloaded with features while eOS is minimalist. I believe what you are looking for is discussed here on superuser. . UPDATE: As you requested terminal scripts I found a GUI program that manages most all of this for you. It is old, but it works, as I am posting this via the Bluetooth from my ...


2

You can disable bluetooth using the following command in terminal sudo rfkill block bluetooth To disable it completely, run the following command in terminal sudo scratch-text-editor /etc/rc.local Add "sudo rfkill block bluetooth" command to the line before last. This command will run during start-up of os automatically to disable bluetooth every ...


2

Because of where I use my laptop at times, I also needed to have the machine boot with Bluetooth off. Here is how I did it: I installed dconf-editor. This can be done via the AppCenter or at a command line by typing sudo apt-get install dconf-editor then entering your password. Open dconf-editor from the app menu. Navigate to org-> pantheon-> desktop-> ...


2

First, unblocking solution found there rfkill unblock bluetooth systemctl enable bluetooth.service systemctl start bluetooth.service afterwords the solution for the bluetooth audio from this link sudo apt-get install pulseaudio-module-bluetooth pactl load-module module-bluetooth-discover Then try deleting/removing the device from bluetooth devices and ...


2

So, I tried a lot of different ways of doing this. First, make sure your user is in the bluetooth group. $ sudo usermod -G bluetooth -a <your_username> Restarting your bluetooth service (and making sure it is enabled to start on boot) should be the next thing you try after checking the rfkill status - see other answers here on that. $ sudo ...


2

In my situation the initial keyboard recognition [it did "see" the KB] was stuck in my Elementary OS bluetooth panel and it would neither connect nor could I delete it. (I thought that deleting it from the panel might allow me to start trying to Pair from scratch - refreshed.) But, I could never delete it even after turning the KB [keyboard] off and ...


2

You can disable the Bluetooth service. sudo systemctl stop bluetooth sudo systemctl disable bluetooth


1

I think I have a solution. sudo apt-get install linux-headers-generic git build-essential git clone https://github.com/jeremyb31/bluetooth-4.4.git cd bluetooth-4.4 cp /usr/src/linux-headers-$(uname -r)/.config ./ cp /usr/src/linux-headers-$(uname -r)/Module.symvers Module.symvers make -C /lib/modules/$(uname -r)/build M=$(pwd) modules sudo cp btusb.ko /lib/...


1

Update: Solved after update to new kernel 4.8 {linux-generic-hwe-16.04}


1

As a temporary fix for your situation - you can just add the command to run automatically on startup. Open up Settings -> Applications -> Startup (tab) Click on the + icon in the bottom left. type bluetooth on in the custom command section.


1

Most of your issues are known bugs. About the missing bluetooth icon on system settings... try installing it: sudo apt install switchboard-plug-bluetooth


Only top voted, non community-wiki answers of a minimum length are eligible