Hot answers tagged

16

I tried installing pm-utils and invoking sudo pm-hibernate but that didn't work. Can you be more specific? As @Lewis noted, hibernate is disabled by default (even in Ubuntu). If you wish to hibernate manually with pm-hibernate examine the pm-utils logs (less /var/log/pm-suspend.log) for clues. Enable Hibernate If everything appears to be successful in ...


12

I don't have dual graphics, but I do have a Haswell based machine with a GTX 960. I installed the release version of Loki and had slow, stuttering Nouveau graphics even though I had selected to install proprietary drivers during installation. This is what I did to fix it, afterwards I had fully accelerated binary drivers from Nvidia and a smooth, fast ...


8

Update: Should be fixed in the AppCenter 1.2 update, but try the following if it persists: I haven't had this issue since I disabled the AppCenter from running in the background. To kill AppCenter in your current session, run killall appcenter. To disable AppCenter at startup, see Disable AppCenter dock reminder—there is a terminal way and a gnome-session-...


8

Its a bug, already reported: https://bugs.launchpad.net/appcenter/+bug/1617687 Im also affected, hope it will get fixed soon.


5

Got exactly the same issue on Juno stable, and found the solution here: https://superuser.com/a/1315412 The problem basically comes down to the fact that the power settings are not propagated to the 'lightdm' user, which is the active one on the login screen. I fixed my issue as follows, copied from the answer in the above link: sudo -s su -s /bin/bash ...


4

Removing the App Center works for me. sudo apt purge appcenter You can always reinstall it later; after the problems are addressed maybe :).


4

Aside from already suggested answers (force enabling of hibernation, and normal shutdown as apps should resume where they left, which obviously doesn't work for non-elementary apps like LibreOffice etc.), there is a third option: Suspend. If you just want to start a new day where you left the day before, the prefered way is to suspend rather than hibernate. ...


4

elementary OS Freya is designed to resume from where you left it even when you Switch Off the machine. For instance, opening Scratch will, by default, open all the files you were editing last time. As such, a design decision was made to remove it, coupled with the fact that hibernate is hardware dependent, and does not work on many systems.


3

If you are using nVidia graphics, check if you are using the proprietary drivers and if not, enable them. To do that open Slingshot, type in "Additional Drivers" and select it from the opening dialog. If your laptop has an nVidia graphics card, it may be the open source graphics driver causing the problem. The open source graphics driver has some ...


3

Try to add the command to your ~/.profile-file, that should auto-execute this command everytime you log on. But I don't know if it is harmful if the command is executed while the touchpad is working.


3

If you click on the menu entry called Shutdown... it does not turn off the system immediately but instead opens a dialog, where you can also click on Restart (pictured in the middle). Alternatively you can just type "Restart" into Slingshot or use the terminal command sudo shutdown -r now.


3

Figured this out. The settings in System Settings->Power don't seem to make any difference, at least on my particular BIOS or motherboard or whatever. However, this command will fix the problem and prevent the machine from ever sleeping: sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target


2

The command working on freya is: dbus-send --system --print-reply --dest=org.freedesktop.login1 /org/freedesktop/login1 "org.freedesktop.login1.Manager.Suspend" boolean:true The pmi action suspend not working, so To create keyboard shortcut key see here. Reference here


2

My work around, or un-elegant fix is thus. Uncommenting both lines in logind.conf and changing IdleAction=ignore -to- #IdleAction=sleep, setting IdleActionSec=30min to whatever time I desire, I did =5min, then restarting, logging in and waiting the specified time to idle results in the system going to sleep on its own. It would appear that when the systems ...


2

Go to 'System Settings' Select 'Power' Unlock administrator rights Look down and you'll see "When lid is closed:" Choose from menu to the right "Do nothing"


2

This is not a bug. It just checks if there is internet connection. After a while it should print a text 'You are now connected to the internet blah blah blah...'. :) It's just an information for you.


2

Same problem with me, Nvidia GeForce GTX 1050, using the latest 384.98 Nvidia Driver. The problem disappears if I switch the driver to use the "Power Saving Mode" which disables the Nvidia GPU and uses the Intel one instead - the return from suspend is much faster and there are no visual defects like the ones on the picture above. It looks like a problem ...


2

I believe this to be a solution for what you're wanting to do: Open a Files window as admin by right clicking Files and selecting "New Window as Administrator. Navigate in the File System to /etc/systemd and open logind.conf with Scratch Text Editor. Directly below the line reading #HandlePowerKey=poweroff add a new line of text reading: HandlePowerKey=...


2

Have the same issue on Dell XPS 15 even with much newer Nvidia Driver, as workaround switched to Inter Graphic card. Only on Inter Suspend and Resume work good. Waiting for nvidia bug fix.


2

More people seem to have the same issue: https://github.com/elementary/switchboard-plug-power/issues/94 For people interesting in how to switch settings via console: It might be related to an issue in the switchboard app of elementary: https://github.com/elementary/switchboard-plug-power/issues/89 A workaround is explained here: Elementary OS ignoring ...


1

In console: bluetoothctl Connect bluetooth device and see in console. Example: [CHG] Device 00:1F:20:E1:B3:B7 Connected: yes [CHG] Device 00:1F:20:E1:B3:B7 ServicesResolved: yes Copy device code. Trust this device: trust 00:1F:20:E1:B3:B7 This worked for me. Source https://pctuner.club/n/2415


1

To enable bluetooth on every startup you need to add your custom command in etc/rc.local Open terminal and type sudo nano /etc/rc.local Now add the following line before exit 0 rfkill unblock bluetooth It will start bluetooth on every startup.


1

There seems to be an issue with kernel 4.4.0 to 4.5 with open source video drivers. I am no expert but I found this to be a common thread among people with this problem. I updated kernel to 4.6 and it seems to have resolved the issue, albeit creating some smaller issues I am now working on...


1

This is a confirmed bug that located here. I have found the best way to deal with this bug without rebooting is to switch your TTY (CTRL-ALT-F1) and run sudo killall lightdm. It should switch you back to the login screen and you should be able to log in and get back to your desktop.


1

AFAIK this is about the kernel issues. In some devices (Chromebooks), a newer kernel will solve the problem, but others no. I guess you are using BOOT_STUB or full rom firmware. Changing it to RW_LEGACY firmware may help. Here are some links about this problem: https://m.reddit.com/r/GalliumOS/comments/4ux2qc/suspend_not_working_on_swanky/ https://github....


1

This is likely a Kernel or BIOS problem. The first thing you should do is upgrade to the mainline build. Google how to do that. That is likely not to solve your problem. You should file a bug with the kernel google that too. However, you cannot file a bug (it is very rude and they will tell you soo), without upgrading the BIOS and running the mainline. ...


1

As already said in the comment, using a live-system suspend won't resume. The cause is the missing swap partition (or file) with an appropriate filesystem (i.e. not tmpfs). If you insist on using a live-system, you may: config your live-system to never go to sleep and to not suspend when closing the lid, or add another writeable drive (USB, SDHC), format ...


1

This was a confirmed bug in Elementary OS Freya when using nvidia-glx module. I had resolved it by following this post. Run sudo -i scratch-text-editor /etc/default/acpi-support Find and change POST_VIDEO=true to POST_VIDEO=false Find and change SAVE_VBE_STATE=true to SAVE_VBE_STATE=false Restart your laptop, issue should be solved. I think that this is ...


1

I have a laptop the same obsolete GPU.It was having artifacts and I could fix it by running sudo apt-get install mesa-utils sudo mkdir /etc/X11/xorg.conf.d/ echo -e 'Section "Device"\n Identifier "Intel Graphics"\n Driver "Intel"\n Option "AccelMethod" "sna"\n Option "TearFree" "true"\nEndSection' | sudo tee /etc/X11/xorg.conf.d/20-intel.conf sudo reboot


Only top voted, non community-wiki answers of a minimum length are eligible