The Stack Overflow podcast is back! Listen to an interview with our new CEO.

Hot answers tagged

9

Adjust scroll speed This is based directly on an answer to a similar question on AskUbuntu by user stvn66. I have tested it under elementary OS 0.4 Loki. Unfortunately there is no simple setting to adjust scrolling speed right now, which seems to be a problem for many Linux based operating systems, not only elementary OS. Currently the best option is to ...


7

You can test to see if your mouse is broken by running the following in terminal: xev | grep ButtonRelease You'll see a white box with a black square in it. Click the square. Each time you click you will see a line in your terminal window. Ensure that your mouse is only clicking once.


6

If you use synaptics driver you will probably have the synclient program installed. In terminal have a look at you current touchpad settings: $ synclient -l You will get a list with many settings. We are interested in the "TapButtonX options". The X is for the number of fingers, so in your case "Tapbutton3". I guess it will be disabled: TapButton3 = 0 Now ...


5

Edit - This works in Freya NOT Loki Here is my solution for disabling the touchpad in elementary OS when attaching a USB mouse. I created these instructions based on the following websites: https://bbs.archlinux.org/viewtopic.php?id=188918 https://bbs.archlinux.org/viewtopic.php?id=170396 As well as the arch wiki on Synaptics touchpad, but I'm only ...


5

This is a bug reported here if you could contribute your laptop model there for testing purposes. (The issue appears to be that the synaptics driver does not take precedence over the libinput driver.) Some of the reporters had some success from installing synaptics and changing libinput's priority: sudo apt install xserver-xorg-input-synaptics sudo mv /usr/...


4

Explanation xkbset can be used to set various options available in the XKB extensions. This includes such things as mousekeys where one can use the numeric pad keys to move the mouse; Execution Open Terminal install xkbset with: sudo apt-get install xkbset after successfull installation type: xkbset ma 60 10 10 5 2 or try ...


4

Be aware that the input stack simply does not support multitouch trackpads right now. You can interpret or simulate gesture support using things like touchegg, but you won't be able to get 1:1 finger tracking or in-app gestures for things like pinch-to-zoom. This won't be possible until the move to Wayland and LibInput


4

By default, elementary OS has a magnifier that can be used by pressing ⌘++ to zoom in and ⌘+- to zoom out. Note that ⌘ refers to the "Super" key, which on your hardware might have a Windows logo, an Ubuntu logo, or the word "Command".


4

So here is the solution if you are using Parallels to install ElementaryOS Loki There is no Parallel Tools driver issue. It is just Boot Flag setting. After installation of Parallel Tools, shut down and don't start Loki. Go to Settings --> Hardware --> Boot Order There you would see Advanced Settings, where you can set the boot flags. Type there devices....


4

I don't know if this is an firefox bug or not but there are more topics about this Firefox right button on selected text start Inspect Tool not right button menu and Firefox right click issue Also what version of firefox are you using? I have version 62.03 and got no problems with the mouse button/context menu for now. Edit: got a litte fix go to -> ...


3

Thanks for providing the necessary information, after a lot of googling and reading bug reports, it seems the main solutions are as follows, I'll start with the easiest although I know you have already tried it. Adjust the touchpad settings using synclient. synclient -l will give a list of options, for your problem in particular I would start with pressure ...


3

I believe there is some form of acceleration by default. At least on my system that seems to be the case. You can use the xset command to experiment with this behaviour. For example, xset m 50 2 sets the 'acceleration' to 50 and the 'threshold' to 2. The cursor will move 50x times as fast when it travels more than 2 pixels in a short time. For more ...


3

Although I did install xbindkeys, I did not install xautomation, which allowed me to automate and assign key combinations like alt+tab. For a detailed explanation, you can follow the link posted by mazienho which gives a good example how xbindkeys and xautomation are working together. In order to achieve what I was looking for, I added the following lines to ...


3

This is apparently an upstream Ubuntu bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1581088


2

try installing trackpad software, this solved my problem * cat /proc/bus/input/devices * I had to use a glidepoint driver


2

Reverse Engineered ALPS driver People report successful multitouch support with some alps touchpads when using the driver located at this page. Download that file then in a terminal do the following... cd ~/Downloads tar vxf psmouse-alps-1.3-alt.tbz sudo cp -r ./usr/src/psmouse-alps-1.3/ /usr/src/ sudo dkms add psmouse/alps-1.3 sudo dkms autoinstall sudo ...


2

This is not exact the solution you ask for, but: You can switch workspaces by scrolling on open applications in plank, if they are open in different workspaces and plank is configured to show all apps of all workspaces (default).


2

You need to install dconf Editor: sudo apt-get install dconf-editor After, run dconf Editor from applications menu, go to org > gnome > desktop > interface, find position "cursor-size" and input needed size of cursor, for example "36". If cursor size suits for you, you needed to restart system from power menu.


2

Unfortunately there is no setting in elementary OS to adjust this. There is a bug over there at Launchpad. A possible solution could be http://www.webupd8.org/2015/12/how-to-change-mouse-scroll-wheel-speed.html (I have not tried it).


2

Have a look here: Two-finger Scroll is not working for my touchpad of ASUS X200MA Maybe you have better luck in terminal...


2

You can turn it to 0: xset m 00 Run this whenever you turn your pc on, or disconnect/connect your mouse. You can run it on startup, by adding it as a startup script (guide here): #!/bin/bash xset m 00 Give the script a .sh ending.


2

I got this working. Firstly I needed to change the property name. Then I could use that with the xinput command inside ~/.profile. Thanks to this Unix Stackexchange answer, I am able to execute the xinput command after each unlock. Here's what I added to my ~/.profile: simulate_mouse_middle() { xinput set-prop "Wireless Optical Mouse" "libinput Middle ...


2

I also have the same issue. The mouse becomes completely unresponsive. However i could navigate with keyboard. I found a quick solution. Pressing win + space to open the launcher fixes it for me. At least for some time.


2

If I understand correctly, you just want to copy text after highlighting it with a mouse. Correct? You should be able to just alternate-click and select copy. EDIT: 1) A possible solution is to use the middle-button (scroll wheel) copy/paste function. Just highlight the text with your mouse and then click the middle button (scroll wheel). It will paste what ...


2

If you have a Synaptics touchpad (which I believe is on most laptops), you can use synclient to modify these settings. To install simply run sudo apt install xserver-xorg-input-synaptics. In this case synclient TapButton1=0 should do the trick. You can put this in your ~/.bashrc to make it permanent. Refer to the man page for more options.


1

This is a bug tracked at https://bugs.launchpad.net/switchboard-plug-mouse-touchpad/+bug/1627121. In green near the top of the page is "Does this bug affect you?" Click that and register yourself for notifications from the developers.


1

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1568604 I think this bug'll be fixed in loki RC1 A quicker workaround is ctrl+alt+f1 and ctrl+alt+f7


1

This is the same with my problem, my laptop is Dell Vostro 1440, when i press WIN + L (lock the computer), after that when i login the cursor will disappear. I look for this problem and this is the way to fix it but when i logout and login again, i will have the missing cursor again: gsettings set org.gnome.settings-daemon.plugins.cursor active false ...


Only top voted, non community-wiki answers of a minimum length are eligible