Hot answers tagged

20

It is always recommended to leave the 2 latest versions of the kernel, but to remove other kernel versions I used the following commands: dpkg -l | fgrep linux-image- Never remove the kernel shown in uname -r or linux-image-generic-lts-utopic. Finally sudo apt-get purge <package names> for the kernels you want to remove (see screenshot for reference)...


12

You can use this one-liner to automatically clean up all old kernels (make sure to restart the computer before doing this if you have just updated the kernel): sudo apt purge $( dpkg --list | grep -P -o "linux-(headers|image)-\d\S+" | grep -v $(uname -r | grep -P -o ".+\d") ) What it does is uninstall (apt purge) the installed packages (dpkg --list) whose ...


11

There are two reasons why it's a very bad idea to upgrade. elementary OS 0.3 (Freya) is based on Ubuntu 14.04 (Trusty). It will almost certainly not work if you were to update to 15.04 - the packages do not exist for it. 15.04 will be EOL soon; end of life. This means it no will no longer get vital security updates, and so you would need to upgrade again to ...


10

Install from a Repository You can install the latest supported version from the Official PPA. This has the added benefit of being an official build and distribution channel, maintained by VLC themselves. sudo apt-add-repository ppa:videolan/stable-daily && sudo apt-get update && sudo apt-get install vlc


10

According to this tweet from the official elementary OS Twitter account, it won't be possible to directly upgrade. A clean install will be required. See also: Should I download loki beta or freya?


10

There continues to be no officially supported way to upgrade between version of elementary OS. This is due to the installer being a patched Ubuntu/Debian installer with no custom elementary support for upgrades, only detection (which I believe has been upstreamed). Clean installation is the recommended method, this creates a new working environment and ...


9

With reference to your other post, you have followed this AU post. To solve the error open terminal and run: sudo add-apt-repository --remove "deb http://archive.canonical.com/ $(lsb_release -sc) partner" sudo add-apt-repository --remove ppa:versable/elementary-update For hash sum mismatch run: sudo rm -rf /var/lib/apt/lists/* Now run: sudo apt-get ...


8

System Recovery If you are now unable to boot, press (or tap) Shift while booting (right after BIOS post screen) to show the GRUB menu. You can choose an older kernel to boot into from the recovery options menu item. Install 3.19 Kernel sudo apt-get install linux-generic-lts-vivid The above command will install the backported 3.19 kernel from the LTS ...


8

For the moment is impossible to upgrade from one version to other, the problem is that they are based in the LTS versions of ubuntu and you can't upgrade from LTS to LTS, I don't know if the elementary team is working in something to solve this problem in the future, but for the moment is not possible to upgrade the system from one release to other directly. ...


8

You can install manually that program with this : sudo apt-get install software-properties-gtk sudo apt-get install update-manager


8

A fix for this specific issue has just been released in the form of a new packagekit version. If this is not applied automatically, you can do it with the following two commands: sudo apt update sudo apt install packagekit Detailed instructions can be located at https://medium.com/elementaryos/important-update-released-501c9d9f28b


8

Step 1. Update Open up AppCentre Navigate to the Updates tab Install all available updates Reboot if required Now your System Settings > About section should look like the following image. Note that it states "elementary OS 0.4.1 Loki", not 0.4. Step 2. Upgrade Kernel [Optional] While your system now runs the latest version of elementary OS, it may ...


8

While the "suggested" upgrade path is to install Juno from scratch, and if you have your /home as a separate partiton might be the best method to be safe, I've just updated both my PCs with the apt method and all went well. Since Juno is based on Ubuntu 18.04 (bionic) while Loki in based on 16.04 (xenial) it was a simple matter of substituting all ...


7

You can simply run sudo apt-get autoremove to "remove all unused packages" which includes older kernels. You should test a reboot before to be shure the new kernel works! It is more secure to leave the 2 latest versions as John pointed out in his answer.


7

As the answers before were not that clear IMHO, here's an answer: No, do not upgrade to the 15.04 base. Freya is built upon 14.04 LTS and only that. elementary OS' repositories do not even contain packages for 15.04 (or 15.10, for that matter). You will end up with a broken installation. The updating software unfortunately is still something elementary OS "...


7

A temporary solution is - Go to tty1 with CTRL + ALT + F1 then get back to desktop with CTRL + ALT + F7


7

To the first question, you can open a terminal and type: killall appcenter Now the reminder dessapears from Planck. To the second question, you can try to show all the hidden startup applications. Open a terminal and type: sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop Then launch the Gnome session properties from terminal:...


7

This is a known bug: https://bugs.launchpad.net/elementaryos/+bug/1596377 This is the workaround: Significant lag loading panel and dock after login (Loki) mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.disabled


7

To solve the problem "public key is not available: NO_PUBKEY A74F73EFFE70B91C", import the key: wget -q "http://packages.elementary.io/key.asc" -O- | sudo apt-key add -


6

While Ubuntu is derived from Debian, Ubuntu has its own security team. This team is responsible for security updates to land in the Ubuntu software repositories. As elementary OS uses the Ubuntu repositories, it's getting security updates from Ubuntu - While it's possible the Ubuntu security team adapts security updates from Debian, Debian security updates ...


6

Option 1: To solve this install y-ppa-manager.To install open terminal and run: sudo add-apt-repository ppa:webupd8team/y-ppa-manager sudo apt-get update sudo apt-get install y-ppa-manager Now run y-ppa-manager from terminal. When main y-ppa-manager window openend,click on Advanced From the advaced list--> click on Try to import all missing GPG keys ...


6

There isn't currently a way to upgrade from one release of elementary OS to another. From the release announcement: elementary OS Luna users should back up their data and perform a clean install. Upgrading to elementary OS Loki will probably require a clean install as well. Upgrade support is planned for a future version of elementary OS, though.


6

First install the package that provides add-apt-repository if it's not already installed: sudo apt-get install software-properties-common Next, remove elementary OS Beta PPA and replaced it with the stable PPA: sudo add-apt-repository --remove ppa:elementary-os/daily sudo add-apt-repository ppa:elementary-os/stable Refresh the repository information: ...


5

The only main issue : your video graphic card. If you want to change your graphic card, do not forget to uninstall your driver.


5

I would check Software & Updates, Updates. Where it says: Notify me of new Ubuntu Version: Is it set to Never? or something else? Set it to Never.


5

It's a bug that has been reported before, Launchpad: in software source you can't select the updates . Please mark it as "yes , it affects me" and provide more informations if it's needed, or put a bounty on it to attract some developers to fix it.


5

I don't have a crystal ball, but I suppose to look for .Xauthority in your home folder, there might be a permission problem: Press CTRL+ALT+F1 (but if you on mackbook do CTRL+FN+F1) to get to a prompt, and login. Check the permissions and owner of your home directory: ls -l ~/.Xauthority Change the owner of the file, if it is not yours, by chown username:...


5

I solved this problem by uninstalling the Parental Control plugin in System Settings: sudo apt-get remove switchboard-plug-parental-controls Not sure why.


5

This has already been answered however maybe some keywords need to be added to the original question so it can be found more easily. Please let us know which search terms you tried.


Only top voted, non community-wiki answers of a minimum length are eligible