I have a pair of Ghostek soDrop 2 headphones. They're Bluetooth-compatible with a built-in microphone and the ability to make calls if connected to a phone.

I paired them with my Linux computer, which has elementaryOS Loki.

However, the audio quality is ABYSMAL. It's not a glitchy/stuttering kind of bad audio quality; it sounds like you're making a phone call. (Phone call quality is not how I want to listen to music.)

A little research (https://superuser.com/questions/724018/bad-sound-through-bluetooth-headphones) shows that this may have to do with the fact that, since the headphones can answer phone calls, it has a second audio profile that has a lower call quality for those phone calls.

Looking at the list of connected devices in the Bluetooth menu seems to confirm this two-driver theory, since my headphones appear twice.

It appears twice

So now it's just a matter of disabling this second audio profile on my computer, which, according to the post in the link above, has to do with disabling a feature called Handsfree Telephony.

The problem is that the Bluetooth settings has practically no way to do this, let alone change ANY settings for my Bluetooth headphones.

No bluetooth settings

Attempting to disconnect only one of the two profiles from the Bluetooth dropdown menu (see first screenshot) doesn't work either, since disconnecting one disconnects both, no matter if you pick the first or second one in the list.

How can I fix this?

  • My problem is on my ipad. How can i fix it, i have a bluetooth dual driver earphone – Calvin Dec 30 '18 at 4:47
  • I have this problem with my bt earphones as well, when i connect them to my phone and there no solution ive tried has worked. Ive messed with the bluetooth developer options and cleared my bluetooth data and reconnecting my device and shit but nothing works. Sometimes i glitch it and the quality in the earphones and mic is clear but 90% of the time it sounds like the audio from an early 2000's toy phone. too broke to buy expensive earphones and that seems to be the only fix. – Kanacucumber Jul 2 at 19:40

Funnily enough, I found the answer while writing this post, so I might as well write my first-ever Q&A post on StackExchange.

You have to go to Sound Settings and under the options for your Bluetooth headphones, switch the Mode to High Fidelity Playback (or whatever other option there is.)

step 1 step 2

| improve this answer | |
  • 1
    In case you have problems connecting your headset in A2DP mode you can use this script > gist.github.com/pylover/… to reconnect your headset so it works again. You need to install pyton3 to make this script work. In that script there's also a link to the bug report... this has been a problem for a while.. – Maccer Feb 17 '17 at 13:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.