We’re rewarding the question askers & reputations are being recalculated! Read more.
11

The Ubuntu proposed repository recently released version 3.2.21-1ubuntu1 of several libnl* packages. There currently break the networking manager in elementary OS Freya. Step 1. Download the architecture appropriate files for these three packages. libnl-3-200 libnl-genl-3-200 libnl-route-3-200 Step 2. Downgrade the Packages and Restart the Service sudo ...


9

You need to install samba server and make some edits in its config file: sudo apt-get install samba samba-common After that you have to edit the file /etc/samba/smb.conf Just add the following (of course for requirements) to the end of the file: [SharedFolder1] comment = My shared folder read only = yes path = /home/user/samba/shared_folder1 ...


5

The Connection field should contain the protocol and the local address of the printer, something like socket://hostname or http://hostname:631/ipp/. There are several ways to try: Use sudo hp-setup -i in Terminal and follow the instructions Go to CUPS and add the printer from here Find your printer's local IP or (preferably) assign a static IP (either ...


4

Well, quoting this awesome answer on askubuntu, you have to mark the packages on hold: sudo apt-mark hold libnl-3-200 libnl-genl-3-200 libnl-route-3-200 That worked for me really great


4

First open a terminal and launch system-config-printers or search Slingshot for "System-Config". When it's open it looks like this: Right click and check it is shared: Now we have to change the server settings as per this instruction: And then check the two check marks Publish shared printers connected to this system and optionally Allow printing from the ...


4

elementary OS does not have any management access to your router. If this is really caused by Linux (elementary OS uses the same network stack as every other distribution), it's your router's fault. You might want to contact your router supplier (which you did not specify yet).


4

I found a temporarily solution until a fix is released, First connect the usb dongle and wait till it get detected in Disks. Then move on to the Settings->Network navigate to the Ethernet under the devices in the left panel (as shown in the above screen-shot), then press Edit Connections then Add select mobile broadband from the hardware menu. Then go ...


3

Make Linux use 'Local' time To tell your System that the hardware clock is set to 'local' time: sudo nano /etc/default/rcS # change the following section # assume that the BIOS clock is set to UTC time (recommended) UTC=no elementary OS & Linux Mint are based on Ubuntu. So most commands from Ubuntu are also working on elementary OS & Mint.


3

As per x2go Client's "Desktop Environment Compatibility" page, Elementary OS's "Pantheon" shell (of the Gnome Desktop Environment) is officially not supported. You could open a new bug report with "wishlist" severity, following the instructions here. It won't be easy to support Pantheon, because there's already other rather difficult problems blocking x2go ...


3

If it shows up in your network connection list, then just select and click delete. This should stop it from connecting automatically until/unless you attempt to connect again manually.


3

SOLVED the problem was that secure boot was enabled, now wireless connection is shown in the option and works!


3

This came up on ask Ubuntu and I see one of the comments says the answer worked on Loki. Check Here for full details Here's what it says to do. Download this firmware In the terminal: cd /lib/firmware/brcm (If folder doesn't exist then...) sudo mkdir /lib/firmware/brcm cd ~/Downloads sudo mv brcmfmac43602-pcie.bin /lib/firmware/brcm/brcmfmac43602-...


3

I'm not sure what the cause of your problem is, but if it's due to faulty proxy settings, you can solve it by filling your proxy settings at System settings/Network/Proxy. If that doesn't help, let me know how you set your proxy to use apt.


2

After trying other search engines and learning their syntax I was able to come across someone who had a similar issue on Ubuntu 12.04 and was able to fix it using sudo dpkg --reconfigure --all Which had me alter a few things like apache and ssl certs. After a reboot I don't seem to be having the issue anymore. I feel bad that I found the answer so soon ...


2

Go to http://localhost:631 (web-based-printer-setting), select Administration and then checklist Server Settings as follows ...


2

Because this is most visited question regarding this topic on Elementary OS, I have solution for you There is solution described on AskUbuntu To cite the answer: This is caused by a regression introduced with a fix for libnl3 bug #1511735. Resulting network-manager crash has been reported in network-manager bug #1539513 or network-manager bug #1539634 ...


2

That card has some issues with iwlwifi driver in sleep mode. You can turn off the power management with this command from terminal: sudo iwconfig wlan0 power off When you reboot your system you will lost this change, so if you want to make it pemanently, you must modify your driver configuration with the following commands: echo "options iwlmvm ...


2

You might be missing the b43 firmware drivers. Open terminal and check your Wireless card model lshw -C network For models: * BCM4306/3; * BCM4311; * BCM4318; * BCM4321; * BCM4322 (only 14e4:432b); * BCM4312 (with Low-Power a.k.a. LP-PHY). Install with sudo apt install firmware-b43-installer For models: * BCM4301; * BCM4306/2; * BCM4306. ...


2

According to this site, HP Pavilion g7-2268wm does not have Bluetooth http://support.hp.com/us-en/document/c03487531 I even checked the Windows drivers for the machine and couldn't find anything. http://support.hp.com/us-en/drivers/selfservice/HP-Pavilion-g7-Notebook-PC-series/5296086/model/5312246 This post claims that you need Kernel 4.4.0 (Xenial) in ...


2

This is the most problematic network adapter, in order to fix it you need to perform a extensive research, some solutions works for an amount of people, and some not. Useful links: https://archrysler.wordpress.com/2016/05/12/ubuntu-16-04-rtl8723be/ https://www.quora.com/How-do-you-configure-wifi-card-rtl8723be-on-Ubuntu-16-04


2

The problem is in the kernel, whilst version 3.19 supports the Intel 8260 driver it does not contain native support which as you've found means a lot of messing around. I'm told that Kernel v4.2 onwards does support it natively. Newer kernels are available in the standard repos. Wily is v4.2 and Xenial is v4.4. So: sudo apt-get install linux-image-generic-...


2

Currently elementaryOS's Switchboard Network Plug doesn't support VPN connections. This question have been previously asked before (No GUI Access to VPN Connections | OpenVPN | 16.04 Loki Beta Daily PPA) Since then the Devs have been notified and currently there are 2 bug reports about this: https://bugs.launchpad.net/switchboard-plug-networking/+bug/...


2

Its on the wishlist: https://bugs.launchpad.net/wingpanel-indicator-network/+bug/1489486 Seems like its not coming anytime soon tho :((


2

I added network-manager-vpnc and network-manager-vpnc-gnome with apt-get install. After that I am able to add the Connection with GUI tools.


2

Finally got the VPN working after finding the answer in the following link: https://bugzilla.redhat.com/show_bug.cgi?id=1394977 The network manager somehow uses nm-applet (which does not run by default) to access the VPN secrets. You can add nm-applet in the System Settings > Applications > Startup by adding the custom command /usr/bin/nm-applet


2

This issue has been logged as a bug. I'm experiencing a similar issue with Vagrant, which also creates virtual network devices. Rebooting should fix the problem until you run Docker again, but of course the real solution is for that bug to be fixed.


2

Please go to AppCenter(appcenter) over an Ethernet connection and click on the installed tab. If you see bcmwl-kernel-source, install it by clicking on free. Your WiFi(wifi) should be working again.


2

This is not a bug. It just checks if there is internet connection. After a while it should print a text 'You are now connected to the internet blah blah blah...'. :) It's just an information for you.


2

There is a recovery mode on elementary Loki as with Ubuntu. The GRUB menu is just hidden during startup. Press the Esc key before elementary starts to show the GRUB menu and select "Advanced Options". From there, you can select the recovery console with the kernel you wanted. If all else fails, it wouldn't hurt to use a recovery disk to boot into to ...


Only top voted, non community-wiki answers of a minimum length are eligible