Hot answers tagged

9

There currently is no theme that really fits elementary OS, but there is a GNOME theme that adds a headerbar to Firefox. You can find it at https://github.com/chpii/Headerbar It looks like this: You can install it by downloading these extensions and themes: Extension that makes the notifications of Firefox use elementary OS's (optional) GNOME theme ...


6

Since Firefox Quantum, the extensions mentioned in the accepted answer has been discontinued. However, as noted by Mehmet Hanoğlu since Firefox 60+, the feature is supported out of the box. To enable it, open the Customise option in the Firefox main menu and uncheck the Title bar check box. For more information, see the bugzilla bug report or omgubuntu. (...


6

In the article that you've linked, they recommend using the HTitle add-on. Afterwards, you also need to add the headerbar userstyle and set Hide titlebar: Always in HTitle's add-on preferences. There are several other Firefox add-ons that attempt to make it appear more native, but there's only so much that can be done. Firefox just isn't a native Gtk+ app. ...


6

As user pole mentioned above, the answer can be found here: mouse right click double clicks? In the Firefox address bar, type about:config. Go to ui.context_menus.after_mouseup and set it to true. Hat tip to user WebShaped.Biz for providing the answer.


5

You can set your $HOME directory as Desktop in xdg-user-dirs config file (~/.config/user-dirs.dirs). This can be done manually through text editor. Open this file: scratch-text-editor ~/.config/user-dirs.dirs And add this line to the end of file: XDG_DESKTOP_DIR="$HOME/" Result:


4

To get an icon on plank (and in slingshot) an app needs to have a corresponding .desktop file in /usr/share/applications/. The desktop file also handles MimeTypes and lets you specify additional menu options (such as 'Open New Window' etc.) Note: If you install firefox from the apt repositories with sudo apt-get install firefox it will update to v42 and the ...


4

It is clearly related to pantheon-files, or at least in the file-chooser dialog. For example, if nautilus is defined as default file-manager in elementary os loki, firefox will display correct behaviour when saving a file: nautilus-file-chooser shows up with last used directory path remembered. I understand it's just a workaround, but it reveals the issue ...


4

Hopefully this will fix it overtime with version 59 of Firefox. https://www.omgubuntu.co.uk/2017/11/firefox-nightly-adds-csd-option Update: In the latest update of Firefox (Quantum 60.0), this is now working! Just do this Open Menu Customize Untick Title Bar


4

I don't know if this is an firefox bug or not but there are more topics about this Firefox right button on selected text start Inspect Tool not right button menu and Firefox right click issue Also what version of firefox are you using? I have version 62.03 and got no problems with the mouse button/context menu for now. Edit: got a litte fix go to -> ...


3

Yes, they both work great on elementary. I'm using the beta of Firefox Quantum without issue and both the stable and dev version of Chrome. Again, they both run great. You can download Firefox from the App Center. To install Chrome you can either install via: wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb sudo dpkg -i --...


3

The solution is to install gtk3-nocsd package and to preload the small library provided by it by adding something like: env LD_PRELOAD=/usr/lib/gtk3-nocsd/gtk3-nocsd.so in front of the command line launching your firefox. The package is found in this repository. More details here. My own configuration for Firefox looks like this: Edited A quicker way,...


3

I confirm the same behaviour, but don't believe it to be a Linux issue, rather a Firefox issue/setting upstream. Solution: Open new tab in Firefox and type about:config in the address bar. Accept the warning displayed. Search for ui.context_menus.after_mouseup. Change it from false to true. Close tab and test. References: I stumbled on the solution above ...


2

You probably added the official PPA for Firefox Beta to your repositories. In order to switch back to Firefox stable, you need to remove this PPA again. Start Software Updater and click at Settings, now switch to the tab Other Software and search for the following lines: http://ppa.launchpad.net/mozillateam/firefox-next/ubuntu trusty main http://ppa....


2

After trying other search engines and learning their syntax I was able to come across someone who had a similar issue on Ubuntu 12.04 and was able to fix it using sudo dpkg --reconfigure --all Which had me alter a few things like apache and ssl certs. After a reboot I don't seem to be having the issue anymore. I feel bad that I found the answer so soon ...


2

The simple workaround would be use addon: Hide Caption Titlebar Plus


2

I think both Chrome and Firefox use PPAPI, the pepper flash plugin so could be a compatibility issue with that. I would try looking in ~/.xsession-errors or ~/.xsession-errors.old if you have had to reboot. Also if you have an Intel display adapter then try enabling "sna" as the Acceleration Method, it fixes a lot of video issues with some Intel chipsets in ...


2

You actually did install Firefox the safe way inside the OS. However, you used the command line instead of a graphical frontend. So no worries, there is nothing wrong with your Firefox installation, both alternatives have the same result. Under elementary OS / Linux often "there is more than one way to do it…"


2

Install Synaptic Package Manager sudo apt install synaptic launch the program and search for firefox select it, then select Package at the top select Force Version... from the pull down select the version you want click Apply


2

I'm not sure if Sean Patterson's answer is enough to prevent it from being updated by the AppCenter in the future. Hence, I'd also mark the package as held back using ‘apt-mark’ command in terminal with root privileges. For example, making your package say Firefox unavailable for install, up-gradation or uninstall, type: apt-mark hold firefox To make ...


2

There is a theme available which makes Firefox look more native to elementary OS: https://github.com/Zonnev/elementaryos-firefox


1

if you save the torrent file on your pc, then by going to the downloads folder and right-clicking it you can choose which application to open it with. There you should also(however I don't remember how) be able to set it as the default app for that filetype


1

Open synaptic package manager -> find flashplugin-installer -> Mark for comeplete removal -> Apply.


1

This was part of a recent set of updates. The elementary GTK+ stylesheet was updated to make older (gtk2) applications look more like the new ones with the big header bars. Check their new blog post.


1

The links from terminal are opened in your default browser. If you want to open it in chrome, make chrome your default browser...


1

Go to terminal and type: sudo apt install adobe-flashplugin Now, the videos will play.


1

I'm unable to reproduce the error. I suggest right-clicking on the area you want to inspect and selecting "Inspect Element". Look if anything is out of the ordinary or try to toggle the CSS if you don't have the italics element showing like I do above. Page might just need a refresh. Worst comes to worst, reinstall Firefox. It's likely something off with ...


1

Ubuntu maintains the Firefox package that elementary OS uses (both in apt install and in the AppCenter). Ubuntu is pretty good at keeping it up to date. In this case 49.0.1 is only an update for Windows, so it shouldn't be of much importance. But you can download the binary and install it over your old release if you want.


Only top voted, non community-wiki answers of a minimum length are eligible