38

You’re missing the libreoffice-gtk3 package for integration with your GTK+ theme.


19

There are 3 ways. From the repositories - (Older version, not recommended): To install Libre Office just run this command: sudo apt-get install libreoffice or open Software Centre and search for "Libre Office". From an official PPA: This PPA is for version 5.0.X (Recommended): sudo add-apt-repository ppa:libreoffice/libreoffice-5-0 sudo apt-get update ...


11

There are some style packages available: libreoffice-style-crystal libreoffice-style-galaxy libreoffice-style-hicontrast libreoffice-style-human libreoffice-style-oxygen libreoffice-style-sifr libreoffice-style-tango and probably some more... I like and use the "breeze-style": EDIT: I forgot to mention that I installed LibreOffice via PPA (https://...


5

Try installing the transitions by running sudo apt-get install libreoffice-ogltrans in terminal. The transitions should be installed


4

To have a more appropriate look, you can install Sfir icon theme : sudo apt-get install libreoffice-style-sfir After install, open Libreoffice and go to Tools > Options > View section and select Sfir icon and small size. I hope you like it.


3

Just install libreoffice-style-elementary from the distro repositories. You don’t need to uninstall your distro-packaged LibreOffice for the version downloadable from libreoffice.org. After you install this package, the icon theme will be selectable from Tools > Options > LibreOffice > View.


3

Here my fast reply: Step 1 Remove the installed version of Libreoffice sudo apt-get remove --purge libreoffice-core && sudo apt-get autoremove Step 2 Download Libreoffice 6.0 archive from the website in your Downloads folder: https://www.libreoffice.org/download/download/ Step 3 Extract the archive, and enter: sudo apt install -f ./~/...


3

I also had this problem installing LibreOffice from appcenter. Solved uninstalling it with appcenter and installing (also with appcenter) separatedly the Libreoffice applications (writer, spreadsheets...). This installs also LibreOfice environment. Update: I understand that you want to install Libreoffice from app center that's why I gave you an "appcenter ...


3

Solved it. It was actually very simple and my fault. Coming from arch, i don't know how ubuntu based systems are supposed to work. I just installed the repository version of libreoffice and then added the ppa. The upgrade was flawless and I am running libreoffice 5.


2

Open terminal and run the following commands: To install LibreOffice 5 : sudo add-apt-repository ppa:libreoffice/libreoffice-5-0 sudo apt-get update sudo apt-get dist-upgrade sudo apt-get install libreoffice


2

LibreOffice are moving from Gtk2 to Gtk3, it's not complete yet and buggy. And the toolbar does not use the correct css class that's why. The same issue in other distros/themes. Screenshot using the latest version of Libreoffice, Gtk 3.20, Arc theme and Arch as distro.


2

It looks like the version of Libre office you try to install cannot work together with the version of Open Office you have. Try to boot into the recovery mode and fix broken packages from there. To achieve this, choose Advanced options for Elementary OS from the grub bootmenu screen, then Recovery mode. Connect to the network from there first, and after ...


2

Installing libreoffice-impress standalone seems to not bring all the required packages for it to look properly (and I suppose work properly as well?): So I suggest removing LibreOffice Impress, and installing the full LibreOffice bundle. sudo apt remove --purge libreoffice* -y sudo apt install libreoffice After the install is done (it might take a while), ...


2

You can improve LibreOffice's looks and integration into elementary OS by adding the libreoffice-gtk3 package. You might also like the libreoffice-style-elementary package that includes better fitting tool icons too. To install both, open Terminal and enter the following command. sudo apt install libreoffice-gtk3 libreoffice-style-elementary


1

Do you want to mark as answered please, so people facing similar can try: sudo apt-get install libreoffice-writer


1

Ok, so I didn't know the exact name of the package, but apt-get install libreoffice-writer helped and re-linked everything in app center.


1

You can change the behaviour of program such as gedit that use the Gtk+3 filechooser by changing the dconf setting org.gtk.Settings.FileChooser.sort-directories-first using dconf-editor or from the commandline. (gsettings set org.gtk.Settings.FileChooser sort-directories-first true).


1

Install libreoffice-gtk3 and libreoffice-style-elementary. Then go to preferences and select Elementary as default icons. Also use Elementary icons as your default system icons.


1

Libre office should be in the Elementary App Center. In case it is not, from the terminal: sudo add-apt-repository ppa:libreoffice/ppa sudo apt-get update This will add the repository in your package manager and update it. and after: sudo apt-get install libreoffice


1

If you have a program you have installed that gives you a problem, try this: sudo apt-get purge libreoffice sudo apt-get -f install sudo apt-get install libreoffice sudo apt-get -f install libreoffice "sudo -f install" essentially fixes bad installs and missing dependencies/libraries/whatever.


1

I am not sure of why it could happens, but try the following : Install Gnome Tweak Tools sudo apt-get install gnome-tweak-tool Then launch it : gnome-tweak-tool And make sure that everything in Appearance is set to elementary


1

To change user interface language in libreoffice: Make sure the language pack is installed. For this,open "Language & region " in system settings. Click on comple install under "install missing languages" ,if the required language is not available. Note: No need to change any other settings in that tab. 2.Go to libreoffice tools-->> options.. -->> ...


1

tools -> options ->Language Settings -> language you can change the language to the language you want and you installed


Only top voted, non community-wiki answers of a minimum length are eligible