0

New Elementary OS Hera (latest stable release as of yesterday) user here but not new to Linux.

Every time I attempt to install Elementary OS from having the ISO written to a Live boot USB, I get the grub-efi-amd64-signed package failed to install into /target/ error on my mid-2012 MacBook Pro.

I built the Live boot USB using unetbooti I think is the name of it.

  • I've tried installing by deleting all partitions and letting the installer do that work.

  • I've tried manually partitioning by creating an EFI partition of 500MB, a 4GB swap partition and a remaining / partition.

  • I've tried installING without an internet connection.

Installing with an internet connection isn't possible. The Mac boot screen allows me to select a wireless connection but it doesn't stay connected once the Elementary OS installer begins. And I don't have the possibility of a wired connection.

I can't install from the Live View because of some other error. Can't remember it at this time. But the Live View doesn't allow me to set up a wireless connection anyway.

I've spent countless hours on this and have read many solutions that worked for others but not for me. Any ideas?

1
  • I tried with internet too, but still it gives me that error ! Jan 12 at 4:20
0

I never did find a way to install successfully without internet. But I enjoy Elementary OS so much that I found a workaround. Hint: you're going to need internet.

I had another PC with both wireless and ethernet capabilities. I shared its wireless connection via its ethernet port to the laptop I wanted to install Elementary OS on. Ran the installer and it completed successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.