0

I am having difficultly trying to install Loki on my MacBook circa 2007. Firstly following the instructions and using Etcher to burn elementaryos-0.4-stable-amd64.20160921.iso I created a USB stick that booted fine on my mid 2012 MacBook Pro but not on the 2007 MacBook.

I found this blog post https://ubuntuforums.org/showthread.php?t=2266424, and following its instructions of copying bootIA32.efi from Mac Linux USB loader I was able to boot off the USB stick. However when I try installing it always errors with this

grub-install /dev/sda' failed. This is a fatal error

I've tried about half a dozen times and enabled the internet during installation to no avail.

1
  • I have found a explanation and also solution for the issue though it involves using the 32-bit version pommi.nethuis.nl/… Commented Jan 22, 2017 at 21:21

2 Answers 2

1

I had this very problem installing on a similar Macbook. For me, it seems that the problem had to do with the way I created the USB stick. I had been following similar instructions.

Ultimately, I got it to work when I setup the USB stick using Etcher, as described in the Elementary OS setup instructions on their site.

1
  • What model MacBook do you have? I tried this several times to no avail. Commented Jan 16, 2017 at 15:16
0

Ventoy is another neat utility that allows you to select any ISO stored on your USB stick and boot as if it were a CD/DVD.

This has been really key to getting around the 32-bit EFI issue on my mid-2007 MacBook (which it sounds like you have too) and has worked wonders.

I copied the Elementary 6.1 ISO to my Ventoy stick and I’m able to boot into the Elementary Live CD. I also keep the Clonezilla ISO on the stick for recovery and backup.

Give it a shot, it’s sure given my ole little guy new life!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.