1

I have a late 2006 MacBook (MacBook2,1). I downloaded Elementary OS (5.1, Hera) and plunked it on a USB stick. I tried in in "live mode" and all was good. I committed to installing eOS and it was nearly done but died with this error:

Unable to install GRUB in /dev/sda
Executing 'grub-install /dev/sda' failed.
This is a fatal error.

I clicked "OK" and got this: Installer crashed (stuff about auto-filing a bug report)

I clicked "CLOSE" I then got a dialog saying that the installer encountered an "... unrecoverable error" and a desktop session will start so that I may investigate the problem. I clicked "OK" and got a desktop.

When I reboot the machine, I am now presented a grub prompt.

I web searched and web searched and found https://bit.ly/2XcO2Ii and https://bit.ly/3dhpJ1t Both these sites are ostensibly the same.

I followed the magic spell given: I proceed with a "manual boot," i.e.

  • I located (hd0,gpt2)/boot/grub
  • set root=(hd0,gpt2)
  • Got the UUID of the partition
  • Ran linux /boot/vmlinuz...
  • Ran initrd /boot/initrd...
  • Ran boot

The system came up.

Moving on to fixing the EFI partition ...

I ran sudo add-apt-repository ppa:detly/mactel-utils

It failed; turns out I needed to first install "software-properties-common" first ... I did so.

Re-ran sudo add-apt-repository ppa:detly/mactel-utils and got this error:

Err:9 http://ppa.launchpad.net/detly/mactel-utils/ubuntu bionic Release
    404 Not Found [IP: 91.189.95.83 80]
E: The repository 'http://ppa.launchpad.net/detly/mactel-utils/bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

I'm now dead in the water. Since I can't install mactel-boot et al. (as per the web page), this whole endeavor is a failure at this point. I'm at a loss as to what to do next.

I've searched SE for solutions but may are outdated, reference Windows/dual booting, or are straight-up contradictory, e.g. same thread: "The solution is to boot to USB and NOT UEFI" v. "You need to install from the UEFI partition on your eOS USB stick"

For the record, I am NOT interested in dual booting. I do NOT care about preserving the HD's previous content or structure. All I want is a fresh, clean eOS install.

0

Macbook2,1 has 32bit EFI.

Normal grub tries to install 64bit efi loader, so

You need to Install grub-efi-ia32 and run grub-install.

Here I have a bookmark which describes the whole installation process on Macbook2,1. https://cloud-infra.engineer/installing-elementary-os-on-my-late-2006-macbook/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.