1

I have been trying to install Elementary OS 0.3.2 alongside my Windows 10 install. I have my windows 10 on my 120gb ssd and I am trying to install Elementary OS on another 250gb HDD.

First I copied the Elementary OS 0.3.2 iso to a USB stick to live boot and install.

One problem I had was that when I loaded the OS, I had a black screen, so I had to add 'nomodeset' into the GRUB booting settings inorder to get the display working.

After I got the display working, I started the install process. When it started installing the grub it gave the error "unable to install grub in /dev/sda. This is a fatal error."

I then tried burning the iso to a disk instead and trying to install from that instead, because I read online that the USB drive could cause it, however that made no difference.

I then tried using 0.3.1, because 0.3.2 made lots of changes to how the GRUB installs so I figured it was worth a shot. Using 0.3.1 I was able to complete the install with no error pop-ups. The problem however, is that it did not seem install a GRUB at all. In order to load up linux and not windows I must tell the bios to boot on the correct drive.

Also, because there is no GRUB, I cannot add the 'nomodeset' into the GRUB booting settings inorder to get the display working.

I have made sure that Windows secure boot and fast boot are disabled.

2

This always works for me :- 1. download & create liveimage of supergrub iso. 2. boot super grub. 3. locate bootable OS on the pc. ( if more than one OS on the PC) 4. boot you preferred OS. 5. Login & go terminal as root. 6. usually most people prefer grub on "/dev/sda" but that's no always the case. So select the drive you prefer to install grub on. 7. run "grub-install /dev/sd?" change the "?" to the letter of the drive you wish to install grub on. 8. then run "update-grub" that should do it.

you could also run "grub-mkconfig -o /boot/grub/grub.cfg".

Note: A. I always suggest installing "grub-customizer", this is a great graphical app to manage your grub. ie. update,add, change the OS boot order , backup & save grub. Even move to a different drive.

B. Supergrub disk or "RESCATUX" are incredible tools to carry around with you.

  • Thank you, your advice worked and let me install the grub. However, Elementary OS will only load up if I start it in recovery mode, then select resume normal boot sequence. If I attempt to boot Elementary OS normally, I get the logo pop-up for a few seconds, and then I end up on a black screen with " ^[[26# " written in the top left corner. – Matthew Rhodes Sep 7 '16 at 17:12
1

I had the same problem on my HP pavilion 15 with Freya and couldn't find any solution (none of them worked) . Recently I tried Loki beta 2 (It has newer kernel) and was successfully able to install it.

I recommend you to try to install Loki Beta on the laptop. However you may want to wait a few more days as it looks like Loki stable release is on the way and there is no direct upgrade path. If you are comfortable with reinstalling the Loki after few days, you should certainly try it now.

0

Did you install your system to the correct bootloader partition (I may be using the wrong term)? At a point in installation it asks you where do you want to install ("the bootloader" maybe?), and I this caused issues for me in the past, because I've set it to something other than the root of the hard drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.