1

On a laptop where I already have elementary OS 5 installed in BIOS mode (no /boot/efi partition), I am trying to install elementary OS 6 from USB, and I would like to keep the system booting in BIOS, not UEFI, mode. However, the installer always insists on a separate /boot/efi partition in the partitioning step. (This is not the case on another laptop where I tried installing, where just a / partition was sufficient.) I checked the BIOS boot settings, and it's set to Legacy Support (Legacy First). I tried searching for an installer boot option to force BIOS mode but did not come to something. Any pointers are appreciated.

1 Answer 1

0

After researching, it seems that remastering the ISO and deleting the EFI directory would have been the simplest approach. However, I admit my issue turned out to be that the boot USB was showing up twice in the boot menu, and I was selecting the one that boots in UEFI mode, not legacy mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.