1

I'm new to Linux and this is the first time i tried to Linux. My laptop is Dell XPS 9360. When ever i use the to boot elementary OS(i tried Ubuntu too and get the same error message), i get to boot but when i run the installer and at the choose partition page there is nothing to choose. And when i press the + - change button it opens a window telling me installer crashed this is the error message:

 Traceback (most recent call last):
  File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 1302, in on_partition_list_edit_activate
    self.partman_dialog(devpart, partition, create=False)
  File "/usr/lib/ubiquity/ubiquity/plugin.py", line 48, in wrapper
    return target(self, *args, **kwargs)
  File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 983, in partman_dialog
    if ('can_resize' not in partition or not partition['can_resize'] or
TypeError: argument of type 'NoneType' is not iterable

I am using UEFI boot option and I've tried both with secure boot on/off and fastboot on/off. When i tried legacy boot it doesn't even and shows an error message saying,

kernal panic and initramfs unpacking failed junk in compressed archive
  • Hi Edwin, welcome to eOS SE. Your participation is much appreciated. I have made some changes on your post to make it look better though your choice of words DO describe your problem well. – Hasan Jan 8 at 13:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.