0

I have recently tried to install Elementary OS in order to replace Windows 7. My process was the following:

  1. Back up files one external hard drive.
  2. Create bootable Elementary OS USB using Universal USB Installer.
  3. Boot from USB as live.
  4. Erase internal hard drive partition (in attempt to clean things up).
  5. Run installer.

My problem is that when I tried to boot into the newly installed Elementary OS, it simply refused and did not even seem to recognize the hard drive. I have tried installing with and without encryption and using many other options but to no avail. When I use the 'scan disk for faults' utility from the USB I get the message in the title 'kernel panic-not syncing: VFS: unable to mount root fs on unknown block(2,0)'.

Do you have any suggestions (please be kind as I am fairly new to the whole Linux way of thinking).

1

Have the same problem and found out that page: https://www.linux.com/learn/how-rescue-non-booting-grub-2-linux

I used the commands from there: during grub-menu just enter c for commandline, than do that:

set root=(hd0,1)

linux /boot/vmlinuz- (now press TAB many times to find out whats the newest kernel-version. use that) and add root=/dev/sda1 at the end, the full-line should read as the following (but with the right kernel!!) linux /boot/vmlinuz-3.13.0-29-generic root=/dev/sda1

to the same with the initrd (use the same init-rd-version as the kernel version!!)

initrd /boot/initrd.img-3.13.0-29-generic

boot

Now you should even be able to boot into Elementary OS

  • Pressing tab doesn't bring up any autocomplete options for me. – Aaron Franke Jul 30 '18 at 23:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy