5

I recently tried to install elementary OS on my Asus laptop, where I previously installed Windows 10 (it came with no OS when I bought it). The installation is weird: when I proceed with the wizard, it doesn't detect Windows 10 and tells me to either erase everything or to make a custom installation, there are no "Install alongside Windows" buttons. So I proceed with the custom installation. I'm doing this while booting in Legacy mode.

I have around 4 or 5 partition (just 1 hard disk), so I split the bigger one that is around 500 GB. With the newly freed space I create a root partition of around 30 GB, a swap partition (5000 GB) and finally the home partition with the remaining space. All of these created in this order, selecting "logical" and placing them at the "end of the space" (I followed a tutorial). So now I have sda5 (root), sda6 (swap) and sda7 (home).

The installation goes fine, I download the updates during it and it tells me to reboot my PC. When I reboot, after I removed the USB stick as asked, it boots normally into Windows 10. No matter how I turn off the PC (holding Shift, pressing the button etc.) it always boots Windows 10.

I tried to play around in the BIOS but basically I have two settings that determines EFI or Legacy modes: Launch CSM and Launch PXE OpROM policy. I think with both enabled I use Legacy.

Now an othe weird thing. If I boot with those two settings enabled, I boot Elementary OS, but if I disable just one of them I boot into Windows 10. I tried to use boot repair both on my installation of Elementary OS and on its Live CD but it always gives the error that I'm not booting in EFI, which if I do boots Windows so I can't use Boot Repair. On Windows I tried FreeBCD but the program just won't start.

BootInfo by Boot Repair: http://paste2.org/csB5BtBF

3

Ok so this got it working for me.

In the BIOS I kept only Launch CMS enabled (OpROM disabled). Boot menu now has "Windows Boot Manager", the hard drive and the DVD drive. With this combination I boot into Windows 10, install rEFInd and problem solved.

If you don't have Windows Boot Manager in your boot menu you have to disable CMS, save and after rebooting it will go directly into your BIOS again. Go to the boot menu and enable Windows Boot Manager, enable CMS and go back reading the previous paragraph.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.