3

I tried to install elementaryOS on my new HP notebook that I've recently bought for school. The PC has UEFI instead of BIOS, I've followed an online guide for installing elementary OS ( e.g. disable secure-boot,fast boot and legacy boot). If I try to run the OS in live mode it works fine, but if I install it I got a grub problem. In fact (by clicking on key F9) if I set as first device the grub I got a black screen where I should manually load the linux kernel. I've done this (by following an other guide) but, after lonux kernel loading, I got the budybox screen but nothing changes. After the reboot I got the same problem.

I've also tried to install the boot-repair tool which gave me the following message: link. After reboot the problem is still there.

Also, I can set as first boot device windows boot manager and can easly use Windows 10 on the other partition of the same HDD.

Hope anyone could help me. Thanks!

1

Try this.

From windows cmd:

diskpart
list disk
select disk X
clean
create partition primary
select partition 1
format fs=fat32 quick
active
assign

Using (or like) 7-zip for decompress iso image into USB.

In bios settings disable secureboot, legacyboot can (should) be disabled. Save preferences. At start, with USB plugged in, press F9, select "EFI file", select your boot device (USB), go to /EFI/BOOT and select grubx64.efi

1

Here is how you solve this error.

  1. Change your BIOS to use Legacy boot method. (Disable (U)EFI secure boot).
  2. Open Elementary OS Freya on live USB, install boot-repair and repair your pre existing installation like you did before.
  3. Reboot.

Now you can boot from legacy to boot into Freya and use UEFI to boot into Windows. If you get lucky, GRUB will detect your Windows installation as well and will show you option to choose your OS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.