9

There are two easy options. Ctrl + right click on plank and go to preferences. There is a show desktop docklet. Hot corner solution. Install wmctrl sudo apt install wmctrl Then you can use wmctrl -k on in the custom command box.


7

I haven't used commands you mentioned. but here is the solution for what you are asking. first you need to install wmctrl. sudo apt-get install wmctrl then here is the command for minimize. wmctrl -k on this one is for restore all windows. wmctrl -k off hope this will solve your problem. cheers!!


2

Sadly, this is not possible under elementary OS. You could file a feature request; however, keep in mind that developers might want to keep it clean.


2

The first step, install wmctrl package: sudo apt-get install wmctrl Description from the wmctrl homepage: The wmctrl program is a UNIX/Linux command line tool to interact with an EWMH/NetWM compatible X Window Manager. The tool provides command line access to almost all the features defined in the EWMH specification. It can be used, for example, ...


1

Log out. While you're in a login screen, you'll see a small gear icon next to your user name. Click on it and switch the desktop environment to Pantheon. Everything will work as expected. You didn't mess anything up. You have just selected Kodi as your default desktop environment.


1

Plank(Dock) has a hidden settings window for developers/OEMs. Hold Control and right click anywhere on the dock Select "Preferences" Select "Docklets" tab from the Dialog box that appeared Drag "Desktop" item to the Dock Boom!!


1

As far as I know, there is no way to run a command after leaving a hot corner, but you can toggle "Show Desktop" when you touch a hot corner. I've got the following script from this article: You first need to install wmctrl (sudo apt install wmctrl) Save the script: #!/bin/bash status="$(wmctrl -m | grep "showing the desktop" | sed -r 's/(.*)(ON|OFF)/\2/g'...


1

Figured out the problem, the command to hide this window is gsettings set org.nemo.desktop show-desktop-icons false. EDIT: And to fix the desktop instead of disabling it, I just followed this guide and everything works: https://elementaryos.stackexchange.com/a/3841/7699


1

There's an "elementary" Solution for it (pun intended) Keep pressed CTRL Right Click anywhere over plank Click on Preferences Click on Docklets Drag the Desktop icon into plank Profit Docklets in Spanish was translated as Agregados, a really bad translation must say. Better to keep it as Docklets


1

I came looking for a solution to showing the desktop in a single key press and the solution of mapping wmctrl -k on to SUPER + D got the job done. Quite handy if you have a really funky conky monitoring configuration running on the desktop. Note that the above seems to be a half solution though. If you want to restore the windows you were working on ...


1

This problem was caused by the "Enable Desktop Icons" feature in the Tweak tool. Disabling that feature restores the desktop to how it should be.


1

This problem can be caused by installing Nemo file manager. If you have Nemo installed and don't want it, remove it using the Software Center or by running sudo apt-get remove nemo


1

Updating to Freya did solve the problem. I ran sudo apt-get dist-upgrade and everything worked perfectly.


Only top voted, non community-wiki answers of a minimum length are eligible