12

You can change this behaviour either in dconf editor: org -> gnome -> mutter and uncheck the box " workspaces-only-on-primary" or if you do not have installed dconf-editor you can use following terminal commands: gsettings get org.gnome.mutter workspaces-only-on-primary to check the current setting. Probably it is "true". gsettings set org.gnome....


11

This is intentional for the reasons you pointed out. At the moment we can't have independent workspace switching. The window manager sees multiple displays as one big workspace in Luna. This can be frustrating because one of the big benefits of having another display is to have a place for things you always want to see like documentation or chat or your ...


7

You can disable dynamic workspaces: gsettings set org.pantheon.desktop.gala.behavior dynamic-workspaces false You can set the number of workspaces wanted to NUMBER: gsettings set org.gnome.desktop.wm.preferences num-workspaces NUMBER (Nevertheless, even if you use dynamic workspaces, there are actually no "empty workspaces"…).


6

The keys to do this in Loki are Alt-Super Left/Right.


4

You can achieve this by assigning a keyboard shortcut to "Toggle on all Workspaces" in System Settings -> Keyboard. Now when pressing that keyboard combination with your Pantheon Terminal active, the terminal window should appear on all workspaces. Press that same combination again, and the option should get disabled.


4

With dynamic workspaces enabled (which is default in elementary OS), you cannot create workspaces explicitely but a new empty workspace is created by switching to the right of the rightmost existing workspace or a new workspace is created by moving a window right to the rightmost existing workspace. If you disable dynamic workspaces (via the command line ...


4

Empty workspaces are deleted automatically when you stop viewing them.


3

I'm not sure what solution you are actually looking for. If you wanted to restrict the icons to show only from current workspace, you can achieve that with plank very easily. First bring the plank preference with the follow command. (If you have the preference icon in plank docked, that's fine) plank --preferences Head over to the Behaviour tab and ...


3

Nope, without custom scripting, the OS only supports switching between windows in a workspace ("Switch Windows" in Settings > Keyboard) and switching between workspaces (org.pantheon.desktop.gala.keybindings cycle-workspaces-next), but not apps across all workspaces. What you can do, however, is set "Show All Windows" in Settings > Keyboard > ...


2

elementary OS does not currently have this feature. There is an open feature request in Launchpad


2

Sadly, this is not possible under elementary OS. You could file a feature request; however, keep in mind that developers might want to keep it clean.


2

It is possible to create a keyboard shortcut for this setting which seems to work for any window, including those without title bar menu. It's in System settings > Keyboard > Shortcuts > Windows > Toggle on all Workspaces and it isn't assigned by default.


1

Here is a list of many keyboard shortcuts, starting with the ones for managing windows and workspaces. WINDOWS Close Alt + f4 Unmaximize Alt + f5 Toggle Maximized Windows Key + Up Arrow Minimize Windows Key + H Tile Left Windows Key + Ctrl + Left Arrow Tile Right Windows Key + Ctrl + Right Arrow Switch Windows Alt + Tab Switch ...


1

I don't believe there is a way to remove workspaces other than to move or close the app that is sitting in it. To prevent new ones from being created you just need to avoid "activating" one with the keystroke.


1

You cannot use this gnome extension because you are using elementary OS (pantheon, gala) and not gnome-shell. I am pretty sure that you cannot do this under elementary OS, because this functionality is not implemented (and it uses only a single row of workspaces).


1

quite simple actually using wmctrl and sleep. This is what I did: #!/bin/bash wmctrl -s 0 ############################################ # Switches to first workspace [workspaces are # numbered from 0] ############################################ firefox -private ...


1

There was an update which removed these gsettings keys and because of that they do not work anymore. I like this feature so I don't need it but I have found out that there is an option to stop going fullscreen on another space and make spaces fixed again by execution of gsettings set org.gnome.mutter dynamic-workspaces false I have test it a few times and ...


1

You need to change the physical clicking from multitouch to hardware default and you will have right click with options inside mouse and touchpad options Stefan


1

elementary OS does not currently support that as a feature. I've filed an issue on GitHub to track the request, though!


1

Run dconf-editor and search for "mouse" entries. Try to change some options like "acceleration time" or "mouse tracking mode".


1

Working fine for me on Juno 5.0. Just changed key codes: gesture swipe down 3 xdotool key super+Down gesture swipe right 3 xdotool key super+Left gesture swipe left 3 xdotool key super+Right


1

Try right-clicking on the windows title bar and selecting "Always on visible workspace"


1

I use fusuma, which allows you to customize the hotkey that gets sent so you can control either applications or the DE. https://github.com/iberianpig/fusuma


1

Don't know for Freya but in Loki these shortcuts have effectively been changed to Shift+Super+Left/Right and they are working all right. Cf., What is the keyboard shortcut to move across workspaces?


Only top voted, non community-wiki answers of a minimum length are eligible