3

Got elementary OS installed today on a desktop PC.

Got the latest NVIDIA drivers installed, and I noticed that if the screen goes blank (after a few minutes inactivity ), when I log back in I have some weird artifacts in the background. Same happened once when I restarted the computer after being in Windows (I have dual boot)

enter image description here

I suspect somehow the graphics card memory is corrupted when I use elementary, because in the reboot situation I could see fragments from the windows session within those artifacts!

The card is a new GTX 1060 that I have for almost a month now, it works fine with all games in Win10.

Anyone aware of what the problem may be?

  • I get a similar thing when I unlock on my dual-display on Nvidia, but it sorts itself in a second or two. – Lewis Goddard Oct 29 '16 at 21:15
  • For me it stays no matter what I do. I try to change the background but nothing happens. If it makes any difference, I have three monitors connected. – AntouanK Oct 29 '16 at 21:20
1

I had this desktop artifacting with nvidia-367 but it went away when I updated to nvidia-370.

The drivers are still a mess and I still get the artifacting briefly after resuming (with Windows assets, like you mentioned), but the desktop artifacting appears to be over. That's a driver bug, if you find the open ticket (Google is littered with mentions of Nvidia artifacting issues).

  • But 367 are the latest stable, right? ( also, how do you make nvidia X server settings persist? Do I save to an X conf file? ) – AntouanK Oct 30 '16 at 7:28
  • @AntouanK, yep, their website recommends 367.57 right now (perhaps check whether you're updated?) but 370 has been worth it for me thus far. NVIDIA X Server Settings app saves automatically as far as I can tell--never had an issue with that but could be a bug? – wolf Oct 30 '16 at 16:50
  • I change the monitors setup ( one is rotated and I change the order ) and they reset on every reboot. I don't know how to save it, since I'm afraid I'll get the "loop bug" if I save to a xorg.conf file. elementaryforums.com/index.php?threads/… – AntouanK Oct 30 '16 at 18:07
  • 1
    @AntouanK, have you tried setting the monitor order inside the OS Settings app (under Displays)? Might want to open a separate question for the new question if it doesn't work – wolf Oct 30 '16 at 18:09
  • I tried that but it doesn't apply the changes for some reason!! Maybe I have to reboot and try the changes from there first, not from the nvidia X server settings. I'll try that. – AntouanK Oct 30 '16 at 18:11
1

What always works is disabling your NVIDIA card, see Bo rislav's answer.

If you need to use your NVIDIA graphics card and this happens, I would recommend executing gala -r from the Applications menu as a temporary workaround: enter image description here

I'm pretty sure this is a NVIDIA driver issue, but there is an existing Gala issue: https://github.com/elementary/gala/issues/21

0

I have the same issue after waking from sleep on a GTX 970. While I haven't found a permanent fix, opening up the System Preferences and setting your desktop picture (even to the one it's already set to) will clear it up.

  • My workaround for now is using xscreensaver, to not let the monitor sleep. :/ Setting a new desktop background doesn't work for me. – AntouanK Oct 30 '16 at 18:43
0

Similar problem comes to me every time when my computer returns from suspend. With all recommended NVIDIA drivers.

I cannot say that it is a nice solution, but I found that there's no problem if I switch to the Intel GPU(Power Saving Mode) from the NVIDIA X Server Settings app. enter image description here

0

One way to fix a similar problem is to restart the window manager, which causes it to redraw the desktop. Open a terminal window and run:

nohup gala -r &

The -r flag means replace and the ampersand means to run this in the background process. You can then safely close the terminal.

I'm not sure if this would help OP's problem, because changing the background image fixes part of the issues for me.

[EDIT]

One problem after this is that the wingpanel (the top panel of the desktop) doesn't turn black for maximized windows. The solution is to simply kill it and it gets restarted automatically:

pkill wingpanel
  • 1
    Are you sure? If I then close my terminal gala seems to be terminated. I would actually recommend executing gala -r from the Applications menu. – Peter Uithoven Feb 11 '18 at 15:41
  • @PeterUithoven that's what the ampersand & is for. It executes the program in the background. For me this works even when I close the terminal. – ivant Feb 12 '18 at 12:50
  • I know the principle, but for some reason the in the background executed applaction will close if I close the terminal I opened it from. I can reproduce that in a fresh version of elementary OS in VirtualBox. For example with the io.elementary.videos app. – Peter Uithoven Feb 12 '18 at 13:06
  • That nohup fixes that issue for me. I'm curious what could explain the difference between our setup. Do you use a non-default Terminal / bash ? – Peter Uithoven Feb 12 '18 at 13:15
  • Frankly, I'm not sure. I'm using the standard terminal (I love it!) and standard bash. I'll still update the answer to include the nohup, because it won't hurt anybody. – ivant Feb 12 '18 at 20:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.