0

Hello I have a problem with ubuntu installed on my laptop.

The laptop is ASUS K501U with NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2). My System is elementary OS 0.3.2 Freya (64-bit).

The problem is after I installed updates to my system my graphic card drivers broke. When I turn on the computer I get black screen after selecting the system ( I have ubuntu and windows installed) I think that it is working because I can hear the login screen sound.

What I found was : https://askubuntu.com/questions/41681/blank-screen-after-installing-nvidia-restricted-driver

But it only displays the screen with 1024x764 resolution

I found that I can install other drivers from software updates. But selecting e.g nvidia 375.20, which is recommened for this graphic card breaks the display again ( black after rebooting ) and I have to repeat to process from the link above once again and use low resolution.

I also tried this link: https://askubuntu.com/questions/684181/asus-strix-gtx970-unable-to-get-1920x1080-resolution-ubuntu-14-04

But nothing changed, still black screen after reboot.

Please help :(

migrated from askubuntu.com Dec 8 '16 at 10:43

This question came from our site for Ubuntu users and developers.

  • Hope it gives you some orientation: elementaryos.stackexchange.com/a/3729/6398 – Jorge R. Marín Dec 8 '16 at 14:49
  • My recommendation is that you update to elementary OS Loki. My second recommendation is that you check what graphics drivers you have avaliable sudo ubuntu-drivers devices | grep -o nvidia-[[:digit:]]* and install the previous one (not the 375). Also, updating your drivers directly from the Nvidia site is NEVER a good idea. – Maccer Dec 10 '16 at 13:16
  • I solved My problem by installing Ubuntu 16.04. – Maciejek Dec 19 '16 at 12:37
1

It may be due to kernel issues. Try to boot with an older kernel from grub menu as below.

  • Select Advanced options for elementary os
  • Select the kernel which u think is suitable

If that works, you can remove the new kernel while retaining the older one. But be sure to check which kernel u currently using by

uname -r

and try not mess with it.

To remove kernel, replace X.XX.X-XX with kernel version as below

sudo apt purge linux-image-X.XX.X-XX-generic linux-image-extra-X.XX.X-X-generic linux-headers-X.XX.X-XX linux-headers-X.XX.X-XX-generic

Then update the grub

sudo update-grub

Reboot ur system.

  • Maybe include Ukuu as an alternative method of managing kernels. Also the kernel version is mentioned in the Settings > About screen. – Peter Uithoven Dec 4 '17 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.