1

I need your help in sorting out this installation issue.

I had installed Elementary OS successfully, where I gave the permission to allow download of third party software. This is because I need support for NVIDIA hardware for my laptop. My laptop specs are: HP Omen, Core i7, 16GB RAM, 128GB SSD, 1TB HDD with NVIDIA GeForce GTX 1050. I am installing the OS on 128 GB SSD. Once the installation was complete, it asked me to restart. On restart I am getting the following errors and the laptop gets hanged for long periods of time. Similar behaviour is observed when I try to install Ubuntu LTS version.

ERROR FROM UBUNTU REBOOT AFTER INSTALLATION enter image description here

ERROR FROM ELEMENTARY OS REBOOT AFTER INSTALLATION enter image description here

After long hours of no activity, I had to restart the computer. On re-booting, it gave me an option to select "Try elementary OS" (the bootable USB is still plugged in). So I chose this option in search of some hope. This selection leaves me with a blank screen.

Moreover, when I removed my bootable USB and restarted my laptop, I was able to see the desktop screen but when I click on apps like Settings, or Calendar it gets hanged and then I will have to forcefully shut down using hardware keys. If I open a terminal or browser it is not hanging.

I am not able to help myself. Do help me fix this issue. If you need any more information, I will try my best to provide. Please share your thoughts. Thanks in advance

Update: I repeated the entire process again. Installed the new OS by cleaning the entire disk, giving permission to install third party apps. After it said installation is complete, I removed the bootable USB and clicked on Restart Now. When it reboots, it gave usual errors, and then said "Please remove the installation medium, then press ENTER". So I did. Even on this occasion, it got stuck at Synchronizing SCSI cache After some time I just plugged the bootable USB again, and it went past that and now it is stuck at Attached SCSI removable disk. I have no clue what his happening. Sharing the screen.

Update

1

Did you try the obvious things like disabling Secure boot on your BIOS (UEFI, I know)? or using "nomodeset" (as specified here: Elementary OS won't boot past live CD screen)

| improve this answer | |
  • No I hadn't. The issue was with Nvidia drivers. I was under the assumption that elementary os itself will install it, like in the case of pop-os. – Abid Uzair Mar 3 '19 at 6:18
0

Abid Uzair, all Linux distros have problems with Nvidia drivers, even pop!os you need to download the distro made for Nvidia.

| improve this answer | |
  • Ohkay I see. I'd heard from a friend of mine who said he did not have to install Nvidia drivers for pop-os. It was able to install by itself. Although, I haven't tried it first hand. – Abid Uzair Mar 5 '19 at 6:16
0

This is a widely known problem for Nvidia drivers.

The probable way to fix this is using nomodeset (as reported in lot of other places) then installing the proprietary drivers.

It may be true that Pop!OS does not require this step, is reported that they are able to overcome this issue (but I have no idea why).

To fix it on Ubuntu or elementary follow these steps.

Install elementary

  • put the live USB in your computer,
  • during the boot process, press and hold SHIFT key. Now you can see the grub menu.
  • press e key on line "try ementary without installing" to edit it.
  • go to line with the quiet splash sentence. Something like: linux /boot/vmlinuz-4.4.0-57-generic root=UUID=xxxx-xxxx-xxxxx ro quiet splash.
  • add the nomodeset option between ro and quiet splash. You must see someting like: linux /boot/vmlinuz-4.4.0-57-generic root=UUID=xxxx-xxxx-xxxxx ro nomedeset quiet splash.
  • press Ctrl + X to boot the kernel

After installation

  • during the boot process, press and hold SHIFT key. Now you can see the grub menu.
  • press e key on line "elementary" to edit it.
  • go to line with the quiet splash sentence. Something like: linux /boot/vmlinuz-4.4.0-57-generic root=UUID=xxxx-xxxx-xxxxx ro quiet splash.
  • add the nouveau.modeset=0 option between ro and quiet splash. You must see someting like: linux /boot/vmlinuz-4.4.0-57-generic root=UUID=xxxx-xxxx-xxxxx ro nouveau.modeset=0 quiet splash.
  • press Ctrl + X to boot the kernel

This will disable nouveau drivers. At this point I would expect the pc to boot properly (using the Intel video chipset).

Note: if it didn't work, replace nouveau.modeset=0 with nomodeset and try again. nomodeset is more invasive and will disable more kernel features, you should still be able to finish the process.

Install Nvidia drivers

Open a terminal and run:

  • ubuntu-drivers devices you should see your graphic card listed
  • now run sudo ubuntu-drivers autoinstall which should install appropriate graphic card drivers

At this point you should be able to reboot to a properly working system (nomodeset should not be required anymore).

Hope this helps!


All this information was taken from multiple places:


In case you want to use driver more up to date than the one ubuntu-drivers may install, you can refer to this answer: https://askubuntu.com/a/747429/22318

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.