0

My PROBLEM today (numbered below) and SOLUTIONS (lettered A, B and C). Scroll to Solutions below (but may be helpful to see if you have same problem).

PROBLEM: 1)Powered off computer yesterday which I never do since I moved desk. When powered on, system automatically booted to e splash (normal), but no green NVIDIA logo (knew something was wrong...) then went straight to recovery and grub. Tried to just normally boot from there (my first error). Nothing.

2)Powered off and tried to boot into recovery (No keystrokes worked). Tried about 10 times. Zero response.

3)System would boot past e logo, no green NVIDIA logn then into Elementary black login screen and ask for my password. Noticed screen would flicker time at top super quick then update with a time 5 minutes into future (ooh. This little glitch continued at login screen for these 10 attempts. Weird). Would put in password. No error but loop back into same again and again--not accepting password. (*Other user reported this issue in terminal here)

4)Finally, entered password. Hit enter. Hurry for next part before it loops you back into the same password box!

5)For the few seconds of black screen before looping back, decided to enter terminal and it worked (yea)-- I think I did Alt-F2, but Ctrl-Alt-T may also work. You'll be in terminal.

6)I did the following. I'm not sure if first 2 commands (A, B) worked or if it was the last command that worked (C), so I'm putting them all in order. It's possible just C would do it. Others? Thanks. I THINK the problem is with the NVIDIA drivers and is with Linux perhaps and NOT Elementary per one user:

(Copied instructions to myself in case this occurs again. I spent about 2 hours looking up solutions on my phone so perhaps this will help someone else. Thanks. Please note I'm a newbie to Linux so sorry for length and improper terms.)

Please note: *I apologize as I took screenshots of solutions both on this site and on searches for over 2 hours, so I can't attribute solutions to correct thread or author. If it's your solution, please chime in below with my BIGGEST THANKS!

SOLUTION: (see above to enter terminal from black screen and stuck-in-password loop)

From terminal: (also may be to access from recovery or grub)

  1. login with username & password. This time, my password worked fine. Login as root. Elementary is good at telling us commands to use. I learned "sudo" before prompts does this (not sure why it doesn't do this natively)

SOLUTIONS: *please note A and B may not be necessary; maybe you can skip to C, but this is order that worked for me after 2 hours of research/trying to get to GUI:

A) sudo apt-get purge nvidia-*

sudo add-apt repository ppa:graphics-drivers/ppa

sudo apt-get update

sudo apt-get install nvidia-440

(or try sudo apt-get install nvidia-driver440)

B)sudo ubuntu-drivers install

then follow the Elementary prompts (this step may not be necessary)

C)sudo apt-get install xserver-xorg-input-all

reboot

After doing step C, my issue was fixed, I was able to login correctly, and ran software updates (1 available). I cannot say for sure if it was all three steps above in terminal that fixed it or just the final step C, which a user proposed here (can't find--but thank you!).

Maybe this will save someone 2 hours :-).

THANK YOU!

*2009 iMac desktop (wiped, running Elementary only, no dual-boot)

0

You might consider using 'ubuntu-drivers install' instead, it will handle the purging and installing safely.

2
  • 1
    Thanks Feoh. I see you are the one whose above suggestion (B) $ sudo "ubuntu-drivers install" I found at another thread (running Win) . I posted my suggestions since I think my issue was a little different from terminal. Thx! Jul 29 '20 at 16:39
  • Sure! Maybe since you';re giving the answer, mark the question as answered?
    – feoh
    Jul 29 '20 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.