0

After the 7/2/20 updates, I ran sudo apt autoremove. Since then, the first reboot never went to a login screen. The e splash logo hung there all night.

In the morning, I hard rebooted (Power switch on 2011 Mac), then got a grub menu. I went to Advanced, recovery 5.3.0-6.2 generic recovery.

Then sent me to a Recovery Menu. But no navigation options worked. Not arrow keys, not tab. When I tried them, I got all kinds of glitches on the screen, showing root terminal prompts in inverse video, etc., but still leaving me somewhere in that list of options. (Are there some tricks to this kind of navigation on a Mac keyboard?) Eventually I seemed to hit "resume" and the machine did come up. But clearly something is wrong with the boot setup, and this pops up fairly often after upgrade.

I'd appreciate any suggestions.

3
  • Does it show the grub with entries showing Elementary OS on the list after you power on your laptop? – Sysadmin Jul 4 '20 at 19:22
  • It does. elementary is first option then one for the linux version then the linux recovery, then an older linux then an older recovery. – jaslar Jul 4 '20 at 20:12
  • Ok. Then there is an option to get into system. Can you wait till tomorrow and I will write a tutorial step by step, which will explain what to do? Please just turn off the laptop now and do not try to solve the issue on your own. – Sysadmin Jul 4 '20 at 20:16
0

To boot into single user mode you edit the boot instructions for the GRUB menu entry you wish to boot and add the kernel parameter/option single. Brief instructions for how to do this are below.

Turn on laptop and wait when GRUB menu will appear. Select (highlight) the GRUB boot menu entry you wish to use. Use the first one entry in this case.

Press e to edit the GRUB boot commands for the selected boot menu entry.

Look near the bottom of the list of commands for lines similar to

linux /boot/vmlinuz-5.7.0 root=UUID=bc6f8146-1523-46a6-8b
6a-64b819ccf2b7 ro quiet splash initrd /boot/initrd.img-5.7.0

Change the line by removing quiet splash and by adding the kernel boot parameter single to the end of the line (it should look exactly like this: ro single).

For this example you would change:

6a-64b819ccf2b7 ro quiet splash

to

6a-64b819ccf2b7 ro single

Press either Ctrl+X or F10 to boot using these kernel options.

Note: These changes are not persistent. Any change to the kernel boot options made this way will only affect the next boot and only if you start that boot by pressing either Ctrl+X or F10 while still in GRUB edit mode.

Then run the system and see errors on the screen and provide a photo of the screen with errors or information the system shows.

Then you should hit Enter to go into maintenance mode and type in terminal.

journalctl -xb

and hit Enter.

It will show you all information from the boot start process to the end, I mean to the moment you hit Enter to go into maintenance mode. To quit viewing hit q.

Provide screenshots. Use arrows or PgUp PgDown to scroll text in the screen.

To restart type:

systemctl reboot

And hit Enter.

Then you can repeat all steps but instead of hitting Enter, hit Ctrl+d to run the system.

See will it load with default options.

The same effect you will achieve when you will hit Enter instead Ctrl+d and then type:

systemctl default 

and hit Enter.

17
  • Thank you. I will try this. Appreciate the recipe, even if I don't understand it! esp "Repeat all steps." But I'll see how far I get! Thanks. – jaslar Jul 6 '20 at 16:16
  • Repeat all steps means repeat all described by me procedure. The problem with this is that it will not allow to connect remotely and help. Eventually if you have someone who is good in IT and you can trust this person, ask for a help and show this person this thread. – Sysadmin Jul 6 '20 at 18:18
  • OK, I've followed the steps. First hard boot (power switch or software reboot) always leads to an e splash screen that never resolves. Second boot gives me the grub screen. I was able to make the changes you suggest, then could both run journalctl -xb, and get a successful login with Ctrl-D. I've got lots of screenshots of the journal read! This wrestling with boot is making elementary very awkward to use.... – jaslar Jul 7 '20 at 16:08
  • What journal -xb shows? This is very crucial. If you logged into the system and you can use the terminal inside the working system, just type sudo journal -xb and copy the text, just select the output on the screen with the mouse, click right to copy and paste into website pastebin.com . Then provide an URL to pastebin and I will be able to investigate errors. This is not the standard Elementary OS behavior. I provided a way how to get into the damaged system to troubleshoot it, analyze and repair. Something is definitely broken or not properly configured. – Sysadmin Jul 7 '20 at 16:27
  • created the file, created account on pastebin, and was informed that my file is too large to post unless I upgrade to Pro. Can I email you the file? Contact me at jlarue at jlarue dot com. Thanks for your help. – jaslar Jul 7 '20 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.