1

New PC, installed Loki, everything was fine until I downloaded the nvidia drivers using these links:

After I rebooted I try to log in and get kicked right back out. I've tried everything on this thread ( Can't login after upgrade ) besides downgrading the kernel and nothing fixes the issue. When I try to create a new user I can log in via the command line only view, but on the graphical log in screen I cannot pick a new user even though a new user "icon" shows up.

Any help is appreciated.

Update 1: Removed the .Xauthority file per this answer ( https://askubuntu.com/questions/367260/i-am-logged-out-immediately-after-logging-in), restarted lightdm, this did not fix the issue.

Update 2: Moved the .Xauthority file per this answer ( https://askubuntu.com/questions/20929/gnome-x-logs-off-immediately-after-login-which-logfiles-are-relevant/178622#178622 ) this did not fix the issue. Also of note, I can log via text with a different user, but when I try to flip to the graphical mode it boots me back to the graphical log in screen.

Update 3: Per this answer ( https://serverfault.com/questions/384676/linux-closing-connection-after-successful-login ) I made sure /bin/bash was there. It was. I also made sure the shell was there. It was. Something else that might be of interest, I checked the permissions on my .Xauthority file on my working Freya machine, they match the permissions on my Loki machine.

Update 4: This user is having the same problem (I can't login , return to login screen (it isn't Xauthority) ). I uninstalled elementary-tweaks, rebooted, this did not fix the issue. As far as I know I do not have numix-icon installed, whatever that is.

Update 5: Per this site (https://www.computersnyou.com/4947/how-to-solve-ubuntu-login-loop-quick-tip/) I purged/reinstalled lightdm. That did not fix the issue. I purged lightdm and installed gdm. That borked everything. I get a text only login for a second then nothing, my monitor doesn't recognize an input and turns off. At this point I'm researching some sort of repair install. Last resort, reinstall.

Update 6: I can get to a GRUB menu and recovery mode. Not sure what would be the best option here though.

Update 7: Got to the root shell via recovery mode, purged gdm and reinstalled lightdm. That said, it's still not exactly to the way it was before. If I don't get into a text login screen the graphical login screen will flash after a minute or two then the whole screen goes black and the monitor shuts off.

Update 8: Seems like this person was having a similar issue (http://elementaryosandmore.blogspot.com/2013/12/how-to-fix-elementaryos-after.html) I checked for any packages with the word nvidia in them, there were none.

Update 9: Now I'm just trying to uninstall the nvidia drivers via command line. I followed this link (https://ubuntuforums.org/showthread.php?t=1432857 ) and got the following error message when running 'sudo rmmod nvidia' "ERROR: Module nvidia is in use by: nvidia_modeset". I have an xorg.conf file but I'm cautious about changing the settings in the file while the module is still loaded. Additionally, googling that error message got me to this link (https://askubuntu.com/questions/109681/which-process-is-using-nvidia-module) and when I run lsof -n -w -t /dev/nvidia* I get no PID.

1

Success!

sudo nvidia-uninstall

killed the nvidia driver I put in there and returned me back to normal. Thanks https://askubuntu.com/questions/206283/how-can-i-uninstall-a-nvidia-driver-completely . Then (bonus)

sudo apt-get install software-properties-gtk

adds the software & updates app into elementary so you can choose an nvidia driver the correct way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.