1

I'm thinking of trying elementaryOS on my laptop. (Dell Inspiron with Intel i5 & Nvidia)

I have created a live disk with a USB drive and Rufus.

When I boot up my laptop, I chose to boot through UEFI and I can see the splash screen just fine, and the window to choose the language as well as two options, "Try Elementary" and "Install Elementary" (or equivalent). The cursor can be moved and the options can be selected.

Upon clicking on "Try Elementary" (which is what I want to do), the window closes and the cursor disappears, leaving me with a blank, grey screen. I can't do anything at this point and can only restart the device by force (pressing and holding the power button).

I know it's something with my laptop since the live disk works fine on another desktop running Pentium. I have not seen any other help thread with symptoms similar to mine, thus any help would be greatly appreciated.

Thanks in advance.

2

Can you please try hitting the 'e' key in the grub boot menu (text mode), and adding 'nomodeset=1' to the end of the line that starts with 'linux'. Then hit F10 to continue booting.

You should see something like: enter image description here

(Googled image, not the exact line), Basically that's where I'm asking you to add the 'nomodeset=1' value at the end.

thanks!

  • 1
    Hey, it actually worked! I got through to the home screen and can use the system now. Now onto the brightness issue... Thanks! – JingzOoi Jan 5 at 13:17
  • 1
    Thanks. Make sure to mark this as answered and point me to your brightness issue if you want :) – Mudito Jan 6 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.