0

I can't seem to get the eOS installation boot USB to work on the new XPS 7390 DE-- no matter what, I get a black screen after the GRUB menu (all selected options).

What I've tried:

  1. Creating the live USB on macOS, eOS, Ubuntu and Windows, including using Startup Disk Creator on the pre-installed Ubuntu. I created a Ubuntu live USB from Mac and Ubuntu and both boot to a working system, though without Wifi drivers.

  2. Added to the linux string in boot options, following this advice. Specifically, I selected Install ... and pressed e. In the linux ... quiet splash --- screen, I replaced quiet splash with modprobe.blacklist=intel_lpss_pci.

  3. I replaced the above string with nomodeset

  4. I replaced it with intel_lpss_pci.blacklist=1

  5. I double-checked the BIOS options: secure boot was off

Has anyone been able to do this yet? Is there a way to replace the kernel in the eOS installer with 14.15.0-1042-oem? This is the kernel running in the pre-installed Ubuntu.

Thanks!

  • How did you add the boot options? Did you press "e" when you got the "install elementary" menu? Do you have ubuntu 18.04 LTS currently installed? You can get elementary by sudo apt install elementary-desktop – Maccer Oct 8 at 14:58
  • I typed e on each option and entered the boot args, none of them gave me anything but a black screen. Also the elementary-desktop package isn't the same as the distro-- it's unsupported in Ubuntu and unstable. Installing that gives me nothing more than the menu bar and wallpaper. Even the Ubuntu dock remains. – RoboRob Oct 8 at 18:44
1

There is a workaround, but it requires a wired connection and Secure Boot enabled to get started.

There is a bug in the intel_lpss driver which causes booting to fail with Secure Boot disabled. This applies to both the installation media and the finished installation. In BIOS settings, you need Secure Boot enabled for the installation. We'll disable it later. However, you need to do the fixes described later so you can turn off Secure Boot, allowing WiFi drivers and other drivers to be installed.

If you're trying to dual boot, make sure you have Windows installed already and you shrunk the Windows partition to create free space for elementary. Otherwise, you can just go through the installer as normal.

Kernel patch

The easy fix described on ArchWiki is to blacklist the intel_lpss_pci module. However, it doesn't work with the Ubuntu-flavored kernel. You'll need a mainline kernel. And if you just blacklist the module, you'll lose support for touchscreen, 802.11ac WiFi, and other useful things.

The best fix is to recompile the Linux kernel with a patched intel_lpss driver.

git clone https://github.com/torvalds/linux.git

cd linux

git checkout v5.3 # or latest stable

wget https://pastebin.com/raw/sqPv8ShP

git apply sqPv8ShP

The source of the patch is this Reddit thread.

Build the patched kernel using the second method in this answer. Then install the generated dpkg files. The compilation will take 30-120 minutes.

At this point you should be able to boot using your new kernel. In the GRUB menu, select "Advanced options for Elementary OS" and you should be able to see your new kernel and boot from it.

Verify your computer boots properly and if so, you probably want to set your new kernel to be the default. Follow this guide to do so.

You should also disable Secure Boot at this point.

Wifi

The XPS uses a Killer AX1650 wireless chip. The drivers are not included in the installation by default. You can follow this guide to install them.

Bluetooth

You already have the linux-firmware repository from the last step, so

cp -r linux-firmware/intel/* /lib/firmware/intel

and reboot. Your WiFi and Bluetooth should be working now.

Remaining drivers

Open AppCenter and update to get the 5.1 update and drivers for various peripherals, including video acceleration. Reboot again and check out the new greeter.

Original instructions are on my blog. It's written for the 2-in-1 but it seems like it should work for the clamshell version too.

  • Your participation is much appreciated👍 Let me inform you that we love informative answers with step by step guide. Please try to include the answer here and leave the source link. Have a nice day! – Hasan Oct 13 at 9:01
  • Really appreciate you putting this guide out there, but sounds too unstable to go with on my primary work machine. Hope they can get an updated kernel and drivers into the installer, missing eOS already. I'm marking this as the answer, even though I've decided not to try it myself. – RoboRob Oct 13 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.