0

I just bought a new Metabox laptop with no pre-installed OS. I downloaded eOS v5.1.5 and installed it on the laptop with no issues. However, when I booted the laptop for the first time after installation (and each time thereafter), it gets to the login screen (I see my username, background, etc.), I enter my password, then after a few seconds of a blank screen with just the cursor, it displays the 'e' logo then shuts down.

Interestingly, I've noticed that it also happens when using the 'try' feature of the live USB (computer shuts down before booting to the desktop). However, doing the same thing with Linux Mint (running it off the live USB) doesn't have any issues (I can boot to the desktop fine).

The only thing I can think of is drivers. But the issue is I'm on a public wifi that requires a login via a webpage to connect (so I can't download drivers during the installation).

Any ideas?

UPDATE: I've since tried installing Linux Mint 19 on the laptop, and while it installed and booted ok (though without wifi), it did eventually freeze up and then try to shut down (similar to what happens with eOS).

1

I got it working. I believe the issue was not having internet during installation in order to download necessary drivers, etc.

To make sure it wasn't a hardware/warranty issue, I installed a copy of Win 10 on the laptop. During installation it asked for internet access, so I tried that and it actually popped up with the browser login thing. So I was able to connect to the wifi and Windows installed and worked properly.

When I then tried eOS again, I enabled wifi and it didn't ask for the login (I believe because the system had already authenticated my MAC address and so didn't need to again). So with internet enabled it installed fine and then worked properly after that.

All in all, the issue seemed to be specific to having a wifi connection that required a browser login (and eOS needing to download certain things for my specific hardware to work properly). If I was at home instead of a hotel, I believe I wouldn't have had any issues at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.