2

So I grabbed Odin today, checked the checksum post download and used etcher to flash it on a usb drive. I booted from the flashdrive and eOS started in live mode, so far so good. I was able to click through the whole installation process without any issues. At the end it tells me to either shutdown or reboot and if I do nothing he counts down for a reboot. After that reboot I am being flashed 2 or 3 times for about 1 sec the following.

Failed to open \EFI\BOOT\{white rectangular char with a black questionmark in it} - Invalid Parameter
Failed to load image \EFI\BOOT\{white rectangular char with a black questionmark in it} - Invalid Parameter
start_image() returned Invalid Parameter

I am using a Dell XPS 13 9380 from 2019. Any ideas on how to fix this or what the issue might be?

2

This is being tracked upstream here: https://bugs.launchpad.net/ubuntu/+source/shim/+bug/1937115

It's affecting Dell users trying to install Linux from live images using a specific version of the shim/shim-signed packages (see the proposed bug fix at https://github.com/rhboot/shim/pull/393), and that includes elementary 6. We can only wait.

6
  • I don’t really know what the github thing does bird I am able to install Ubuntu 20.04. I thought eOS6 builds on top of that. Or is the issue related to the “special” eOS/popOS installer that differs from the ubuntu one? Can I alternatively somehow install Ubuntu and replace the package sources with eOS sources and install everything manually? I want eOS6 :(
    – Jita
    Aug 11 at 1:54
  • 1
    The current Ubuntu 20.04 installer image (.2) works, but they do mention the next one won't unless they fix it (bugs.launchpad.net/ubuntu/+source/shim/+bug/1937115/comments/41). I imagine eOS is based on 20.04 + updates, hence it contains the problematic shim package. Unless you're comfortable with building the live image yourself, I wouldn't attempt a fix.
    – cynic
    Aug 11 at 2:23
  • Also, you may want to look at elementaryos.stackexchange.com/questions/28295/…, using the workaround (manually adding the boot option in the firmware setup) I was able to boot the live image.
    – cynic
    Aug 11 at 2:57
  • I can boot the USB stick into live mode. After the install I can not boot the freshly installed system and get the above error.
    – Jita
    Aug 11 at 11:32
  • The workaround from the other question may still work for you. Basically, you need to create a boot option in the BIOS yourself, with its contents the same as the original elementary boot option, except pointing to grubx64.efi instead of bootx64.efi.
    – cynic
    Aug 11 at 12:44
2

elementary is tracking this here: https://github.com/elementary/triage/issues/74

And there's a workaround:

Downloading an Ubuntu 20.04.2 iso and copying the EFI folder from it to the elementary media (overwriting the original EFI files) seems to work as a workaround.

I will try this workaround myself, as I am also affected by this problem.

UPDATE: A new image has been released with a correction for this problem. Get it at elementary.io

10
  • Please check back in and keep us posted if it worked for you. I couldn’t figure it out. The stick is either read-only. Or if you copy the iso contents manually not booting properly. At leas I didn’t manage to make it work.
    – Jita
    Aug 11 at 19:01
  • @Jita it worked. You need to create a GPT partition table on the stick, add a FAT32 partition, mount it and copy the contents of the elementary iso into it. When that's done, delete the /EFI directory from the stick, mount the Ubuntu 20.04.2 iso and copy its /EFI directory to replace the one you just deleted. See this: github.com/elementary/triage/issues/74#issuecomment-896709835 Aug 11 at 19:37
  • I did that, and now when the stick boots. It tells me it can’t grub theme.txt. Then I get a grub boot menu where I can select “try or install elementary os” when I do so it boots into the stick or at least tries to because it doesn’t get me to the installer. I get the error “Unable to find a medium container a live file system” and then “Attempt interactive netboot from a URL?” I select “no” and then I’m in “BusyBox v1.30.1” built-in-shell (ash) and get the prompt “(initramfs) Unable to find a medium containing a live file system”
    – Jita
    Aug 11 at 19:53
  • I formatted the stick with gparted, added a gpt partition table, formated to FAT32 again, then set its flags to boot. And copied the extracted contents of the odin iso file. Then I deleted /EFI/boot/ contents and replaced its contents with the contents of the same folder of the 20.04.2.0 ubuntu iso
    – Jita
    Aug 11 at 20:00
  • I don't know whether this will make a difference, but you don't need to set any flags. If I'm not mistaken, that's only necessary for legacy MBR booting. Oh, and another thing, did you notice that elementary has a directory named /EFI/boot while Ubuntu has /EFI/BOOT? I used the latter on my elementary stick. So, in short, you replace everything inside /EFI, including the boot directory. Give it a try. Aug 11 at 21:05
0

You can go into the Dell BIOS (F2 in my case) and then under boot options you can manually add a UEFI entry to boot off BOOTx64.EFI which is in EFI/boot folder of the USB stick. That worked for me.

Note: Beta 2 didn't have this issues, so it must have been that shim change as per the previous commentary.

1
  • I can boot the USB stick into live mode. After the install I can not boot the freshly installed system and get the above error.
    – Jita
    Aug 11 at 11:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.