1

Really want to install Elementary but ..

I have a Dell all-in-one which has been running Linux Mint Tricia dual booted with Windows 7 without problem for a few months.

I would love to replace Linux Mint with Elementary OS, I need to keep W7 for Adobe CC use.

I wiped Linux Mint, re-extended the partition and set about installing Elementary next to W7.

I made boot media and was pleased to find it ran beautifully in “live”mode.

Every attempt to install it though has ended in the same way; the install seems to proceed as expected and I am finally asked to remove the USB install media and press enter. I am met with a black screen with a cursor.

Forcing a reboot gives me an option menu Windows / Elementary / Elementary other. I can access Windows from here but choosing Elementary leads me to the same black screen and curser.

I did try one of the “Elementary other” options but that was no better.

I have tried installing from USB and DVD; same result

I have tried installing with/without updates and drivers.

Googling the problem indicates that this is a problem that others have experienced and nVidia graphics is mentioned as one area of difficulty… fast boot was also mentioned..

I poked around my non-eufi bios and didn’t find any means of switching off my graphics card or any reference to fast boot … I considered taking the back off the pc and disconnecting the connection to the nVidia graphics card but google tells me that the card is welded to the board ..

So having spent 2 days trying, I eventually gave up and went back to Linux Mint (another Ubuntu derivative of course) which installed first time without problem.

I am not here to moan but to ask for help. Any idea where I can go from here ? Surely the fact that I can boot to a “live” session suggests that an installation should be possible ….

With thanks for your time

K

0

This sounds exactly like the problem I had with a recent elementary update.

If your Dell all in one uses Nvidia graphics, get to the Grub menu (If you're booting Elementary automatically with no menu, hold down the Shift key).

Then you should see several entries, one with the latest kernel (Mine's 5.4.0-48). Pick the one after that that'll look something like 5.4.0-48 (Recovery).

Once you get to the recovery menu, choose "Enable networking". Then choose the "root' option to get a root shell.

Once there, run the following command: ubuntu-drivers install

This will install the latest Nvidia drivers and may well fix your problem as it did for me.

| improve this answer | |
  • Many thanks for your reply. I will uninstall Mint, extend the partition and start again noting your advice. At the point of installation where it asks whether I wish to install updates and/or 3rd party drivers, would your advice be to tick these or not? Thanks again. K. – user23583 Jul 29 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.