I really like Elementary OS so I tried to install Loki on my laptop. It is a Lenovo Y570. Here are specs: https://www.cnet.com/products/lenovo-ideapad-y570/specs/

Video is NVIDIA GeForce GT 555M / Intel HD Graphics 3000 - 1 GB

. First of all, I had a lot of trouble installing it. I was getting a black screen before the login screen with the live disk but I found the nomodeset trick for nvidia cards. Still the screen was messing up (possibly when locking) during the install process that way, but I was able to install without any issues using the straight install partition with the nomodeset option.

Now I have an OS that boots, but the login screen is funny. My user name is there but there is no user name on what should be the guest account login. The login screen will accept my password but once entering it the login fields disappear but nothing else happens. There is no touchpad or keyboard response at this point, so I can't even flip to a text session and do anything.

Freya worked fine for me. I install it with the live image and there aren't any issues.

Can anyone help?

  • The guest session won't show any name unless you select it. Can you press Ctrl+Alt+F1 instead of login? – Maccer Nov 18 '16 at 9:49
  • You are right about the guest session. Yes, I can access the text console with Ctrl+Alt+F1 before signing in. When I switched to the tty screen from the login screen I got a bunch of error messages and now this screen appears locked as well. Here are some of the error messages: – malibu Nov 18 '16 at 14:36
  • When I switched to the tty screen from the login screen I got a bunch of error messages and now this screen appears locked as well. Here are some of the error messages: 'Restarting adapter queue is full' 'Error sending REPLY_LEDS_CMD: enqueue_hcmd failed: -28' MANY OF THESE: 'usb 2-1-port1: cannot reset (err = -110) 'Cannot enable. Maybe the USB cable is bad?' And it ends with this repeatedly: 'NMI watchdog: BUG: soft lockup - CPU#2 stuck for 22s! [systemd-timesyn:717] – malibu Nov 18 '16 at 14:42
  • Please note that I didn't have anything plugged into USB at the time but for the flash drive I just installed Loki from. – malibu Nov 18 '16 at 14:50
  • It looks like it is a long ongoing Ubuntu bug, since back to 15.10: bugs.launchpad.net/ubuntu/+source/linux/+bug/1530405 If anyone has anything helpful to recommend then please do. I guess Ubuntu is not my friend any more nor is anything based on it. :-( – malibu Nov 18 '16 at 18:58

The guest session won't show any name unless you select it.

About the rest, It seems that the bug is related to your graphics card. You need to install the correct driver. Go into any tty (Ctrl + Alt + F1 - F6) and log in. First, update your system:

 sudo apt update && sudo apt upgrade 

Then do (just one of the following lines):

sudo apt install nvidia-prime nvidia-current nvidia-settings

or if you prefer the latest stable driver:

sudo apt install nvidia-prime nvidia-367 nvidia-settings
  • How do I install the driver? The OS locks up 30 seconds after booting to the login screen no matter what I do. – malibu Nov 19 '16 at 13:55
  • can you add to the grub options at boot acpi=off ?? You can edit a boot entry pressing F2 when the grub menu appears. If you are not sure where to put this, look for quiet splash and put it in the middle. Then boot and try again. – Maccer Nov 19 '16 at 14:37
  • Also from the bug you have mentioned earlier, some say disabling USB 3 from the bios/firmware could also do the trick. – Maccer Nov 19 '16 at 14:38
  • I understand how to edit grub options, but what will acpi=off do for me? I will try it and report back if I see anything different happen. – malibu Nov 20 '16 at 1:24
  • 1
    Yeah I did not persist nomodeset and acpi=off anyway and yes it does work without now that the drivers are installed. To anyone coming here after... The grub menu is the one that pops up during boot. It will give several options, the main one being 'elementary'. To edit the grub option, with the 'elementary' option press 'e' to edit the command that it will start the kernel with. Scroll down to the line linux which will have a command with a bunch of parameters containing 'quiet splash'. Edit as explained above and hit F10 to boot with it. – malibu Nov 20 '16 at 16:24

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.