I've tried to install elementary OS on a late 2010 27" iMac with ATI Radeon 4670. The test run via thumb drive worked fine, but after installation and reboot a black screen occured.

My problem is that rEFInd doesn't allow the interruption of startup procedere (SHIFT and ESC won't work) for NOMODESET parameter. How can I enter the Grub2 startup menu? And after that, how can I fix the ATI display driver issue?

Any help is highly appreciated! :)

Update: Any tips available? I'm still facing this issues

Btw - is it recommended to use rEFInd as a boot loader for a dual boot OSX/Linux system? Or should I go with the Mac boot loader (pressing 'alt' during start)? Does this fix my problems with entering Grub menu?

3 Answers 3


My Solution

I edited the /etc/default/grub file's command line parameters, so that it reads:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0"

(your system's parameters may vary. Just look for the GRUB_CMDLINE_LINUX_DEFAULT value, and add radeon.modeset=0 to the end, before the close-quote)

Saving the file, running sudo update-grub made this the default boot instruction.

Good to know: setting "radeon.modeset=0" disables any attempt by the Linux OS to use the GPU's hardware acceleration. I think this is what Suzamax meant when claiming that Linux is "not going to work properly" on these old Radeon iMacs.

I would not say this makes Linux a bad choice for these old machines in general, however. I'm writing this on a 2010 iMac that Apple no longer "supports" with the latest MacOS or Safari. Basic usage had broken down, to the point where even ordinary web tasks like youtube videos were failing to load properly, due to outdated browsers with no modern HTML5 support.

Long story short, losing graphics acceleration in a nearly decade-old machine is a fair trade-off. This computer is not going to be used for high-end gaming and video applications.


Meanwhile, the core i3 CPU scores higher in Passmark than most brand new "budget" PC's available right now (which also have no discrete GPU -- purchasing a new low-end laptop would mean the end-user gets the same lack of GPU graphics processing, but they'd also get LESS CPU speed and less RAM, and they'd have paid new money for the lower-utility product):


I always recommend keeping old machines with strong CPU's and SATA connectors (for SSD upgrade) in use, rather than prematurely turning them into e-waste.

To that end, Linux is WONDERFUL for these old iMacs, because it's not like anything else is going to run on them. Apple made sure of that. The only other place this machine was headed was a landfill.


ATI Radeon Mobility 4670 + iMac? Forget about Linux working properly, just use a VM in specific cases or think about getting another computer.

Also, you can press F2 in rEFInd and write radeon.modeset=0 if you really want to use it, but it's better not.

It's my desktop PC (unless I am on a late 2009), and it's resolved in AskUbuntu in my question of the same issue.

Also, I like rEFInd, but it's not mandatory.


I have a mid 2009 iMac 27"
I installed Ubuntu 20.x
I ran into similar issues but followed these steps and now works fine:

After installation, I went into LiveCD mode (try Ubuntu). Its the only way to fix permanently (ie not during startup everytime). But it's a bit tricky when you have to fix this when running from a Live CD. Essentially the idea is to mount the installed Linux from within the LiveCD. I did that, and it helped me a lot. So here are the steps:

  • Run from the Live CD, and either install Ubuntu or move on if already done
  • Check your installed partition with the command "gparted". It opens a Window telling you where you installed Ubuntu. In my case it was /dev/sda2 which contained an ext4 partition.
  • Mount the partition: sudo mount /dev/sdXY /mnt Then mount/bind the directories Grub needs to access like this:
sudo mount --bind /dev /mnt/dev &&
sudo mount --bind /dev/pts /mnt/dev/pts &&
sudo mount --bind /proc /mnt/proc &&
sudo mount --bind /sys /mnt/sys
  • Then move on to this environment using chroot
sudo chroot /mnt
  • You should now be able to edit /etc/default/grub now.
sudo vi /etc/default/grub

and change the line


PS: I found it very useful to also remove quiet and splash so I could see something moving on behind the scenes.

  • The only thing left for me was update-grub
sudo update-grub

Rebooted and the new settings where in place. With the "nomodeset" option I was able to boot Ubuntu and Lubuntu from a MacBook Pro harddisk.

Good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.