The issue has occurred after the accepted solution to https://unix.stackexchange.com/questions/675425/regular-update-broke-initramfs-on-elementary-os-6/675476#675476

This is how my screen looks when I power on my laptop

Error on booting

The prompt is as follows:

BusyBox v1.30.1 (Ubuntu 1:1.30.1-4ubuntu6.3) built-in shell (ash)
Enter 'help' for a list of built-in commands.


Edit: How do I try the fsck command? Can you elaborate? Before turning off my computer I updated intramfs of all the kernels. So none of the kernels is booting. Should I chroot and use update-initramfs to create new initramfs? I guess initramfs is causing my problem, grub and boot partitions are fine.

Clarification: After following the accepted solution for my previous question, the problem with apt was solved and I was relieved. I quickly made my move to update all the kernel initramfs. After doing that I checked for updates, there were none. I rebooted to check if everything was fine, but I landed up here.

I suspect the problem is specifically with initramfs, although you can feel free to ask any other information to better understand the problem I am facing

I don't know if this is the proper way to respond/keep the thread active but can anybody elaborate what exactly am I supposed to do? Do I need to chroot? If yes then with what Distro? if no then do I need to enter the commands suggested to me in the busybox command line interface? I know something has went wrong with all of my initramfs. What is our objective? Do I update initramfs again or create new? I don't need to mess with grub and boot partition right? I will appreciate any help. Thank you.

This same thread on Unix stack exchange: https://unix.stackexchange.com/questions/675486/elementary-os-6-not-booting-drops-into-initramfs-prompt

I am suspecting that this is an issue about my initramfs, after my apt broke, due to intramfs issue while updating, I fixed it with help of askubuntu forum and once that was fixed I updated intramfs for all my kernels. I guess I need to chroot using elementary os and recreate the initramfs. Can you diagnose the error in the photo. It may be due to Plymouth or nvidia as well.



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.