0

I got my Mac book Pro back from service and of course I tried booting Elementary OS from USB that was made with Unetbootin and boots on Lenovo x220.

First boot resulted in ACPI PCC probe failed. Googled it and found solution to hit e key in grub menu and add nomodeset in kernel parameters. Tried again and this time I get busybox terminal after this message:

(initramfs) unable to find a medium containing a live file system

screenshot of error msg

Any ideas what might be the cause of this?

Edit: Elementary OS installed on Virtual Box in El Capitan installed and booted without a hick.

  • Have you changed boot order? If done, change USB socket and try again, and let me know. – Ravan Nov 18 '15 at 3:23
  • The USB might be corrupt. Copy elementary OS to the USB again (I recommend Rufus if you have a Windows PC or Unetbootin for Ubuntu ) and try – Suici Doga Feb 17 '16 at 4:35
  • What did they do at service ? Maybe a hardware component was changed – Suici Doga Mar 23 '16 at 3:36
  • Whole motherboard was changed because this model has a recognised GPU issue. – Hannu Soini May 5 '16 at 12:41
1

The possible fixes:

  1. Check Boot order

  2. Disable ACPI from BIOS

  3. Change the port for the USB_stick connection

  4. When elemenary is booting from live usb hit Del/F10 then choose F6 (Other Options).

    then check acpi=off & nodmraid.

  • There's no BIOS in Macbook, it's an EFI only laptop. I tried both USB ports with the same result. I will comment on the recommended boot options after more testing. – Hannu Soini Nov 18 '15 at 16:21
0

If your laptop has a dvd drive, I recommend you boot from a live dvd. Insert the dvd and hold alt/option key until the dvd drive shows.

-2

Try this:

https://sevenbits.github.io/Mac-Linux-USB-Loader/

It worked on my Macbook Pro 2010

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.