0

First time I'm totally lost with linux :/ I guess there must be a first time for everything! :P

The problem I'm having is I cannot boot into elementary. I select it in the grub and the after the elementary logo the screen stays black. I have a windows 10 dual boot if it matters...

I've tried recovery mode, but honestly I dont know how to fix it from the console since I dont even know what the problem is...

Last thing I did was creating a folder in /etc/X11/ trying to modify the synaptics driver. After failing I removed it, but as far as I know I did it correctly, so it shouldnt be the problem. I also updated the system through the app center.

Any help on where should I start to detect the fail?

Thanks in advance, I looking fordward to continue using it!

EDIT: Well, it looks like I did mess it up with the synaptics driver. After booting into the terminal, I executed startx and I saw there was an error related to 40-synaptics.conf file. I deleted all the text I added and voilá!

Thanks everyone!

1

Are you able to tell whether is just the screen staying black or the whole OS not booting ? I've been having a similar issue on Macbook Pro with an AMD chipset, I was able to tell it had something to do with the graphics since I was able to hear elementaryOS when changing volume, the following link helped:

Black screen when installing OS

  • Thanks Guillaume. I have no idea what rEFInd is. Is it a Mac thing? Anyway I dont understand whi the drivers stopped working suddenly... – jpm92 Feb 19 '17 at 17:48
  • rEFInd is useful only for Macs. Don't worry about it if you're not using one. – Axel Advento Feb 20 '17 at 13:43
  • Well, I guess I will have to format and reinstall. I can boot into the recovery mode, I've tried boot-repair and apt update and upgrade...with no success :( – jpm92 Feb 20 '17 at 14:52
  • rEFInd is indeed a mac thing, but the discrete graphics issue might be for any machine – Guillaume M Feb 21 '17 at 9:57
0

You might try loading a different kernel version ( if you haven't run a sudo autoremove after upgrade, these kernel files must be present)

Go for 'advanced options' in grub and select a previous kernel version in the boot options.

The OS should successfully boot now.

If it still stays in black, it should be a graphic driver problem

  • Well, it looks like it's a graphical problem then, same black screen with older kernel. What I dont know its what caused it since I didnt change any drivers. – jpm92 Feb 19 '17 at 17:47
  • So, you could try the following. Press 'e' while in grub , with the selection over elementary os in the list and add 'nomodeset' before the commands 'quiet spash' so that it looks like this 'nomodeset quiet splash' Now hit on Ctrl+X and boot – Shankar Feb 23 '17 at 9:04
  • As I wrote on the EDIT it was s touchpad thing, I booted from the console and edited the file from there and it worked! Thank you all anyway :) – jpm92 Mar 16 '17 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.