5
sudo apt-get install wine
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     wine : Depends: wine1.6 but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

And:

 sudo apt-get install playonlinux
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     playonlinux : Depends: wine or
                            wine-unstable but it is not installable
    E: Unable to correct problems, you have held broken packages.

While all PPAs are disabled and Ubuntu repos are enabled:

enter image description here

enter image description here

Otherwise there isn't any problem with the packages:

sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

After following instructions from askubuntu,

  sudo apt-get -u dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

So, no fail here.

But the initial error persists in terminal.

What happens in Synaptic is different! When trying to install playonlinux the packages to be removed included all my system so to speak. That would have completely broken the system. It is too long a list to post here.

When trying to install wine, it seems possible enter image description here

but this is contradicted by the terminal output posted above for sudo apt-get install wine, and all this looks fishy to me.


UPDATE

Trying to install wine in Synaptic, it does not work in fact: once selected to be installed, the wine package is marked as broken and some unmentioned packages are signaled as broken.

enter image description here


How to identify the broken packages? Is it possible they being signaled as broken to be an error?


UPDATE after comment from Tim:

~$ sudo apt-get install wine1.6
[sudo] password for cipeos: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.6 : Depends: wine1.6-i386 (= 1:1.6.2-0ubuntu4)
           Recommends: winbind but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

UPDATE after RolandiXor' s answer:

According to the answer, a certain dependency, shown in italics, has to be installed manually:

For Wine1.6 is Wine1.6-i386, for playonlinux is python:any.

enter image description here

enter image description here


UPDATE after trying to follow this solution on ubuntuforums - Installing wine is not possible

The idea is to make /etc/apt/sources.list support multiarch by adding [arch=amd64,i386] to the deb-line and also use aptitude. And then, try sudo aptitude --full-resolver -f install wine1.7.

~$ sudo aptitude --full-resolver -f install wine1.7
[sudo] password for cipeos: 
The following NEW packages will be installed:
  fonts-horai-umefont{a} fonts-wqy-microhei{a} libasn1-8-heimdal:i386{ab} libcapi20-3{a} libcapi20-3:i386{a} libdb5.3:i386{a} libexif12:i386{a} libgd3:i386{a} libgif4:i386{a} libglapi-mesa{a} 
  libglapi-mesa:i386{a} libglu1-mesa:i386{a} libgphoto2-6:i386{ab} libgphoto2-port10:i386{ab} libgpm2:i386{a} libgssapi3-heimdal:i386{ab} libgstreamer-plugins-base0.10-0:i386{a} 
  libgstreamer0.10-0:i386{a} libhcrypto4-heimdal:i386{ab} libheimbase1-heimdal:i386{ab} libheimntlm0-heimdal:i386{ab} libhx509-5-heimdal:i386{ab} libieee1284-3:i386{a} 
  libkrb5-26-heimdal:i386{ab} liblcms2-2:i386{ab} libldap-2.4-2:i386{a} libltdl7:i386{a} libmpg123-0:i386{a} libncurses5:i386{a} libodbc1{a} libopenal1:i386{a} libosmesa6{a} libosmesa6:i386{a} 
  libpcap0.8:i386{a} libroken18-heimdal:i386{ab} libsane:i386{ab} libsane-common:i386{ab} libsasl2-2:i386{a} libsasl2-modules:i386{a} libsasl2-modules-db:i386{a} libusb-1.0-0:i386{a} 
  libv4l-0:i386{a} libv4lconvert0:i386{a} libvpx1:i386{a} libwind0-heimdal:i386{ab} libxpm4:i386{a} ocl-icd-libopencl1{a} ocl-icd-libopencl1:i386{a} p11-kit-modules:i386{a} p7zip{a} 
  ttf-wqy-microhei{a} unixodbc{a} wine-gecko2.34{a} wine-gecko2.34:i386{a} wine-mono4.5.4{a} wine1.7 wine1.7-amd64{a} wine1.7-i386:i386{a} winetricks{a} 
0 packages upgraded, 59 newly installed, 0 to remove and 0 not upgraded.
Need to get 168 MB of archives. After unpacking 543 MB will be used.
The following packages have unmet dependencies:
 liblcms2-2 : Breaks: liblcms2-2:i386 (!= 2.6-3ubuntu1~trusty1) but 2.6-3ubuntu1~trusty is to be installed.
 liblcms2-2:i386 : Breaks: liblcms2-2 (!= 2.6-3ubuntu1~trusty) but 2.6-3ubuntu1~trusty1 is installed.
 libsane-common : Conflicts: libsane-common:i386 but 1.0.23-3ubuntu3 is to be installed.
 libsane-common:i386 : Conflicts: libsane-common but 1.0.23-3ubuntu3.1 is installed.
 libkrb5-26-heimdal : Breaks: libkrb5-26-heimdal:i386 (!= 1.6~git20131207+dfsg-1ubuntu1.1) but 1.6~git20131207+dfsg-1ubuntu1 is to be installed.
 libkrb5-26-heimdal:i386 : Breaks: libkrb5-26-heimdal (!= 1.6~git20131207+dfsg-1ubuntu1) but 1.6~git20131207+dfsg-1ubuntu1.1 is installed.
 libroken18-heimdal : Breaks: libroken18-heimdal:i386 (!= 1.6~git20131207+dfsg-1ubuntu1.1) but 1.6~git20131207+dfsg-1ubuntu1 is to be installed.
 libroken18-heimdal:i386 : Breaks: libroken18-heimdal (!= 1.6~git20131207+dfsg-1ubuntu1) but 1.6~git20131207+dfsg-1ubuntu1.1 is installed.
 libwind0-heimdal : Breaks: libwind0-heimdal:i386 (!= 1.6~git20131207+dfsg-1ubuntu1.1) but 1.6~git20131207+dfsg-1ubuntu1 is to be installed.
 libwind0-heimdal:i386 : Breaks: libwind0-heimdal (!= 1.6~git20131207+dfsg-1ubuntu1) but 1.6~git20131207+dfsg-1ubuntu1.1 is installed.
 libhcrypto4-heimdal : Breaks: libhcrypto4-heimdal:i386 (!= 1.6~git20131207+dfsg-1ubuntu1.1) but 1.6~git20131207+dfsg-1ubuntu1 is to be installed.
 libhcrypto4-heimdal:i386 : Breaks: libhcrypto4-heimdal (!= 1.6~git20131207+dfsg-1ubuntu1) but 1.6~git20131207+dfsg-1ubuntu1.1 is installed.
 libheimntlm0-heimdal : Breaks: libheimntlm0-heimdal:i386 (!= 1.6~git20131207+dfsg-1ubuntu1.1) but 1.6~git20131207+dfsg-1ubuntu1 is to be installed.
 libheimntlm0-heimdal:i386 : Breaks: libheimntlm0-heimdal (!= 1.6~git20131207+dfsg-1ubuntu1) but 1.6~git20131207+dfsg-1ubuntu1.1 is installed.
 xserver-xorg-lts-utopic : Conflicts: libglapi-mesa (>= 0~) but 10.1.0-4ubuntu5 is to be installed.
                           Conflicts: libglapi-mesa:i386 (>= 0~) but 10.1.0-4ubuntu5 is to be installed.
 libgphoto2-port10 : Breaks: libgphoto2-port10:i386 (!= 2.5.3.1-1ubuntu2.2) but 2.5.3.1-1ubuntu2 is to be installed.
 libgphoto2-port10:i386 : Breaks: libgphoto2-port10 (!= 2.5.3.1-1ubuntu2) but 2.5.3.1-1ubuntu2.2 is installed.
 libasn1-8-heimdal : Breaks: libasn1-8-heimdal:i386 (!= 1.6~git20131207+dfsg-1ubuntu1.1) but 1.6~git20131207+dfsg-1ubuntu1 is to be installed.
 libasn1-8-heimdal:i386 : Breaks: libasn1-8-heimdal (!= 1.6~git20131207+dfsg-1ubuntu1) but 1.6~git20131207+dfsg-1ubuntu1.1 is installed.
 libsane : Breaks: libsane:i386 (!= 1.0.23-3ubuntu3.1) but 1.0.23-3ubuntu3 is to be installed.
 libsane:i386 : Breaks: libsane (!= 1.0.23-3ubuntu3) but 1.0.23-3ubuntu3.1 is installed.
 libheimbase1-heimdal : Breaks: libheimbase1-heimdal:i386 (!= 1.6~git20131207+dfsg-1ubuntu1.1) but 1.6~git20131207+dfsg-1ubuntu1 is to be installed.
 libheimbase1-heimdal:i386 : Breaks: libheimbase1-heimdal (!= 1.6~git20131207+dfsg-1ubuntu1) but 1.6~git20131207+dfsg-1ubuntu1.1 is installed.
 libgphoto2-6 : Breaks: libgphoto2-6:i386 (!= 2.5.3.1-1ubuntu2.2) but 2.5.3.1-1ubuntu2 is to be installed.
 libgphoto2-6:i386 : Breaks: libgphoto2-6 (!= 2.5.3.1-1ubuntu2) but 2.5.3.1-1ubuntu2.2 is installed.
 libglapi-mesa-lts-utopic : Conflicts: libglapi-mesa but 10.1.0-4ubuntu5 is to be installed.
                            Conflicts: libglapi-mesa:i386 but 10.1.0-4ubuntu5 is to be installed.
 libglapi-mesa-lts-utopic:i386 : Conflicts: libglapi-mesa but 10.1.0-4ubuntu5 is to be installed.
                                 Conflicts: libglapi-mesa:i386 but 10.1.0-4ubuntu5 is to be installed.
 libgssapi3-heimdal : Breaks: libgssapi3-heimdal:i386 (!= 1.6~git20131207+dfsg-1ubuntu1.1) but 1.6~git20131207+dfsg-1ubuntu1 is to be installed.
 libgssapi3-heimdal:i386 : Breaks: libgssapi3-heimdal (!= 1.6~git20131207+dfsg-1ubuntu1) but 1.6~git20131207+dfsg-1ubuntu1.1 is installed.
 libhx509-5-heimdal : Breaks: libhx509-5-heimdal:i386 (!= 1.6~git20131207+dfsg-1ubuntu1.1) but 1.6~git20131207+dfsg-1ubuntu1 is to be installed.
 libhx509-5-heimdal:i386 : Breaks: libhx509-5-heimdal (!= 1.6~git20131207+dfsg-1ubuntu1) but 1.6~git20131207+dfsg-1ubuntu1.1 is installed.
The following actions will resolve these dependencies:

      Keep the following packages at their current version:
1)      libasn1-8-heimdal:i386 [Not Installed]             
2)      libglapi-mesa [Not Installed]                      
3)      libglapi-mesa:i386 [Not Installed]                 
4)      libgphoto2-6:i386 [Not Installed]                  
5)      libgphoto2-port10:i386 [Not Installed]             
6)      libgssapi3-heimdal:i386 [Not Installed]            
7)      libhcrypto4-heimdal:i386 [Not Installed]           
8)      libheimbase1-heimdal:i386 [Not Installed]          
9)      libheimntlm0-heimdal:i386 [Not Installed]          
10)     libhx509-5-heimdal:i386 [Not Installed]            
11)     libkrb5-26-heimdal:i386 [Not Installed]            
12)     liblcms2-2:i386 [Not Installed]                    
13)     libldap-2.4-2:i386 [Not Installed]                 
14)     libosmesa6 [Not Installed]                         
15)     libosmesa6:i386 [Not Installed]                    
16)     libroken18-heimdal:i386 [Not Installed]            
17)     libsane:i386 [Not Installed]                       
18)     libsane-common:i386 [Not Installed]                
19)     libwind0-heimdal:i386 [Not Installed]              
20)     wine1.7 [Not Installed]                            
21)     wine1.7-amd64 [Not Installed]                      
22)     wine1.7-i386:i386 [Not Installed]                  

      Leave the following dependencies unresolved:         
23)     winetricks recommends wine                         
24)     wine1.7-amd64 recommends libosmesa6                
25)     wine-gecko2.34 recommends wine1.5-amd64            
26)     wine1.7-i386:i386 recommends libosmesa6:i386       
27)     wine1.7-i386:i386 recommends libsane:i386          
28)     wine-gecko2.34:i386 recommends wine1.5-i386:i386   


Accept this solution? [Y/n/q/?] 

Seems that aptitude gives a lot more info. But trying a few options there it comes down to installing 0.

  • You cound try it with the official wine ppa - launchpad.net/~ubuntu-wine/+archive/ubuntu/ppa – pawel.ad Jul 5 '15 at 16:59
  • What is the output of sudo apt-get install wine1.6? – user3 Jul 5 '15 at 20:48
  • @Tim - Answer to your comment in update to question. – user170 Jul 5 '15 at 22:41
  • In synaptic, if you enable to option to show package details in the main window in your settings, you can go to the dependency list, and the package causing the broken package warning will be in italics. – RolandiXor Jul 6 '15 at 0:53
  • @RolandiXor - please try to be more clear. I provided a lot of precise info. What do you mean "show package details"? What package exactly? You mean repos added by me? That is not accessed necessarily through Synaptic. -- All this is so weired, I can confirm (again) that in Synaptic when trying to install playonlinux the packages to be removed include a lot of my system! Wine is also in the list, although not installed. – user170 Jul 6 '15 at 14:08
1

Open Synaptic and go to Settings>Preferences, then check "Show package properties in the main window":
SPP

Now, find the package that is broken, and under its properties, click dependencies. In the list you will see a package that is in italics.
Package Properties

I have no broken packages so mine are not in italics.

Once you've identified this package, you'll need to install it manually. It seems to be winbind in your case. It probably cannot be installed automatically because it depends on something else, which Synaptic cannot mark for installation for some reason.

  • Updated question with the results! – user170 Jul 7 '15 at 9:53
1

The main idea is to use aptitude and its larger options.

The answer follows this one on ubuntuforums.

  • Made /etc/apt/sources.list support multiarch by adding [arch=amd64,i386] to the deb-line:

deb [arch=amd64,i386] http://fr.archive.ubuntu.com/ubuntu/ trusty universe

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo dpkg --add-architecture i386
sudo apt-get update

Update of the database now showed separate amd64 and i386 repos to be loaded.

Next I switched to aptitude, because of the more sophisticated dependency-solver:

sudo apt-get install aptitude

sudo aptitude --full-resolver -f install wine1.7

Full details: http://pastebin.com/Z9Ww11SU

What I did in short:

  • aptitude suggested a solution where wine1.7 would not be installed, that was selected first (20)
  • This solution was rejected with r 20 -- it was a bit complicated for me, I just replicated the commands from the other answer: first selected 20 instead of YES or NO; then r 20 (rejecting the removal of Wine 1.7);
  • then n (It seems that unless you choose Y, YES, aptitude --full-resolver gives you new options after each decision; I guess in this case was NO because it said "dependencies unresolved" for Wine);
  • the next step provided the good solution: to install Wine and to downgrade 14 packages:

ibasn1-8-heimdal libgphoto2-6 libgphoto2-port10 libgssapi3-heimdal libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libkrb5-26-heimdal liblcms2-2 libroken18-heimdal libsane libsane-common libwind0-heimdal

  • So, last one was Y YES, and Wine 1.7 was installed.

  • After that, the installation of playonlinux went without problems:

The following NEW packages will be installed:
  libwxgtk-media2.8-0{a} mesa-utils{a} playonlinux python-wxgtk2.8{a} python-wxversion{a} 
0 packages upgraded, 5 newly installed, 0 to remove and 0 not upgraded.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy