1

When attempting to install Steam, I get this error message:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: steam:i386 : Depends: libgl1-mesa-glx:i386 E: Unable to correct problems, you have held broken packages.

I've searched through other forums and they all suggest essentially the same things, all of which I have tried, to no avail.

2

This is a common problem to install steam and hace happened to many users. To install steam you need to install some 32-bit libraries Run the following command:

sudo apt-get install libgl1-mesa-glx-lts-utopic:i386

Then install steam, everything should work fine.

  • I tried installing the required packages, but it says they are already installed. – ans318 Mar 24 '16 at 1:03
  • The following packages have unmet dependencies: libcheese-gtk23 : Depends: libclutter-1.0-0 (>= 1.13.2) but it is not going to be installed Depends: libclutter-gtk-1.0-0 (>= 0.91.8) but it is not going to be installed Depends: libcogl15 (>= 1.15.8) but it is not going to be installed libcheese7 : Depends: libclutter-gst-2.0-0 (>= 0.10.0) but it is not going to be installed and etc... – ans318 Mar 24 '16 at 1:05
  • Attempting to install any of the dependencies yields this error: E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. – ans318 Mar 24 '16 at 1:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.