I just installed elementary OS.

Cannot install playonlinux or wine.

I prefer playonlinux.

~$ sudo apt-get install playonlinux
[sudo] password for cipeos: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 playonlinux : Depends: wine or
                        wine-unstable but it is not installable
E: Unable to correct problems, you have held broken packages.

Synaptic wants to remove about the whole of my system.

In the past I was able to fix something similar with the inhanced features of aptitude - here.

But now I couldn't, and I am in this position:

~$ sudo aptitude --full-resolver -f install playonlinux
[sudo] password for cipeos: 
The following NEW packages will be installed:
  attr{a} fonts-horai-umefont{a} gcc-4.8-base:i386{a} 
  gcc-4.9-base:i386{a} gnome-exe-thumbnailer{a} icoutils{a} libaio1{a} 
  libasn1-8-heimdal:i386{a} libasound2:i386{a} libasound2-plugins:i386{a} 
  libasyncns0:i386{a} libavahi-client3:i386{a} 
  libavahi-common-data:i386{a} libavahi-common3:i386{a} libc6:i386{a} 
  libcapi20-3{a} libcapi20-3:i386{a} libcgmanager0:i386{a} 
  libcomerr2:i386{a} libcups2:i386{a} libdb5.3:i386{a} 
  libdbus-1-3:i386{a} libdrm-intel1:i386{a} libdrm-nouveau2:i386{a} 
  libdrm-radeon1:i386{a} libdrm2:i386{a} libedit2:i386{a} libelf1:i386{a} 
  libexif12:i386{a} libexpat1:i386{a} libffi6:i386{a} libflac8:i386{a} 
  libfontconfig1:i386{a} libfreetype6:i386{a} libgcc1:i386{a} 
  libgcrypt11:i386{a} libgd3:i386{a} libgif4:i386{a} 
  libgl1-mesa-dri-lts-vivid:i386{a} libgl1-mesa-glx-lts-vivid:i386{a} 
  libglapi-mesa-lts-vivid:i386{a} libglib2.0-0:i386{ab} 
  libglu1-mesa:i386{a} libgnutls26:i386{a} libgpg-error0:i386{a} 
  libgphoto2-6:i386{a} libgphoto2-port10:i386{a} libgpm2:i386{a} 
  libgssapi-krb5-2:i386{a} libgssapi3-heimdal:i386{a} 
  libgstreamer-plugins-base0.10-0:i386{a} libgstreamer0.10-0:i386{a} 
  libhcrypto4-heimdal:i386{a} libhdb9-heimdal{a} 
  libheimbase1-heimdal:i386{a} libheimntlm0-heimdal:i386{a} 
  libhx509-5-heimdal:i386{a} libice6:i386{a} libieee1284-3:i386{a} 
  libjack-jackd2-0:i386{a} libjbig0:i386{a} libjpeg-turbo8:i386{a} 
  libjpeg8:i386{a} libjson-c2:i386{a} libk5crypto3:i386{a} 
  libkdc2-heimdal{a} libkeyutils1:i386{a} libkrb5-26-heimdal:i386{a} 
  libkrb5-3:i386{a} libkrb5support0:i386{a} liblcms2-2:i386{a} 
  libldap-2.4-2:i386{a} libllvm3.6:i386{a} libltdl7:i386{a} 
  liblzma5:i386{a} libmpg123-0:i386{a} libncurses5:i386{a} 
  libnih-dbus1:i386{a} libnih1:i386{a} libnss-winbind{ab} libogg0:i386{a} 
  libopenal1:i386{a} liborc-0.4-0:i386{a} libosmesa6{a} 
  libosmesa6:i386{a} libp11-kit-gnome-keyring:i386{a} libp11-kit0:i386{a} 
  libpam-winbind{ab} libpciaccess0:i386{a} libpcre3:i386{a} 
  libpng12-0:i386{a} libpulse0:i386{a} libroken18-heimdal:i386{a} 
  libsamplerate0:i386{a} libsane:i386{a} libsasl2-2:i386{a} 
  libsasl2-modules:i386{a} libsasl2-modules-db:i386{a} 
  libselinux1:i386{a} libsm6:i386{a} libsndfile1:i386{a} 
  libspeexdsp1:i386{a} libsqlite3-0:i386{a} libssl1.0.0:i386{a} 
  libstdc++6:i386{a} libtasn1-6:i386{a} libtiff5:i386{a} 
  libtinfo5:i386{a} libtxc-dxtn-s2tc0:i386{a} libudev1:i386{a} 
  libusb-1.0-0:i386{a} libuuid1:i386{a} libv4l-0:i386{a} 
  libv4lconvert0:i386{a} libvorbis0a:i386{a} libvorbisenc2:i386{a} 
  libvpx1:i386{a} libwind0-heimdal:i386{a} libwrap0:i386{a} 
  libx11-6:i386{a} libx11-xcb1:i386{a} libxau6:i386{a} 
  libxcb-dri2-0:i386{a} libxcb-dri3-0:i386{a} libxcb-glx0:i386{a} 
  libxcb-present0:i386{a} libxcb-sync1:i386{a} libxcb1:i386{a} 
  libxcomposite1:i386{a} libxcursor1:i386{a} libxdamage1:i386{a} 
  libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a} libxi6:i386{ab} 
  libxinerama1:i386{a} libxml2:i386{a} libxpm4:i386{a} libxrandr2:i386{a} 
  libxrender1:i386{a} libxshmfence1:i386{a} libxslt1.1:i386{a} 
  libxt6:i386{a} libxxf86vm1:i386{a} ocl-icd-libopencl1:i386{a} 
  p11-kit-modules:i386{a} p7zip{a} playonlinux python-dnspython{a} 
  samba{a} samba-dsdb-modules{a} samba-vfs-modules{a} tdb-tools{a} 
  winbind{a} wine{a} wine-gecko2.21{a} wine-gecko2.21:i386{a} 
  wine-mono0.0.8{a} wine1.6 wine1.6-amd64{a} wine1.6-i386:i386{a} 
  winetricks{a} zlib1g:i386{a} 
0 packages upgraded, 163 newly installed, 0 to remove and 25 not upgraded.
Need to get 166 MB of archives. After unpacking 573 MB will be used.
The following packages have unmet dependencies:
 libxi6 : Breaks: libxi6:i386 (!= 2:1.7.4-1~14.04~ricotz1) but 2: is to be installed.
 libxi6:i386 : Breaks: libxi6 (!= 2: but 2:1.7.4-1~14.04~ricotz1 is installed.
 libglib2.0-0 : Breaks: libglib2.0-0:i386 (!= 2.42.2-0ubuntu1~14.04~ricotz0) but 2.40.2-0ubuntu1 is to be installed.
 libglib2.0-0:i386 : Breaks: libglib2.0-0 (!= 2.40.2-0ubuntu1) but 2.42.2-0ubuntu1~14.04~ricotz0 is installed.
 libnss-winbind : Depends: samba-common (= 2:4.1.6+dfsg-1ubuntu2) but 2:4.1.6+dfsg-1ubuntu2.14.04.9 is installed.
                  Depends: winbind (= 2:4.1.6+dfsg-1ubuntu2) but 2:4.1.6+dfsg-1ubuntu2.14.04.9 is to be installed.
                  Depends: libwbclient0 (= 2:4.1.6+dfsg-1ubuntu2) but 2:4.1.6+dfsg-1ubuntu2.14.04.9 is installed.
                  Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but 2:4.1.6+dfsg-1ubuntu2.14.04.9 is installed.
 libpam-winbind : Depends: samba-common (= 2:4.1.6+dfsg-1ubuntu2) but 2:4.1.6+dfsg-1ubuntu2.14.04.9 is installed.
                  Depends: winbind (= 2:4.1.6+dfsg-1ubuntu2) but 2:4.1.6+dfsg-1ubuntu2.14.04.9 is to be installed.
                  Depends: samba-libs (= 2:4.1.6+dfsg-1ubuntu2) but 2:4.1.6+dfsg-1ubuntu2.14.04.9 is installed.
The following actions will resolve these dependencies:

      Keep the following packages at their current version: 
1)      libglib2.0-0:i386 [Not Installed]                   
2)      libgstreamer-plugins-base0.10-0:i386 [Not Installed]
3)      libgstreamer0.10-0:i386 [Not Installed]             
4)      libnss-winbind [Not Installed]                      
5)      libpam-winbind [Not Installed]                      
6)      libxi6:i386 [Not Installed]                         
7)      playonlinux [Not Installed]                         
8)      wine [Not Installed]                                
9)      wine1.6 [Not Installed]                             
10)     wine1.6-amd64 [Not Installed]                       
11)     wine1.6-i386:i386 [Not Installed]                   

      Leave the following dependencies unresolved:          
12)     winetricks recommends wine                          
13)     winbind recommends libnss-winbind                   
14)     winbind recommends libpam-winbind                   

Accept this solution? [Y/n/q/?] 

When trying the available options to replicate the solution of my older answer (see link above) I get to a point where too much of the whole system is bound to be removed.

Is there a way out?

UPDATE after answer:

I was able to install playonlinux from the deb using gdebi, but without "some dependencies".

When starting playonlinux, Wine, xterm and icoutils were reported absent. Icoutils and Xterm can be installed in terminal, and then in playonlinux I can install specific Wine versions by going to 'Tools - Manage Wine versions':

enter image description here

Those on the right were manually installed.

But then I cannot make a certain .exe file to be installed with one of the Wine versions. When starting an installation the normal way the installation crashes, but a virtual drive is created. When trying to select a specific Wine version for that drive it is not remembered. To make one of the installed Wine versions be remembered by a virtual drive I have to create a drive manually and set a Wine version for it in the first place when asked for one. Selecting the virtual drive in 'Configure', and then, under 'Miscelaneous', the option to 'run a .exe file in this virtual drive', the installation crashes in the first case (when Wine not remembered), and leads to an odd situation in the second case (drive created manually) where Wine is remembered and even the .exe seems to start running but without any window (I see an icon of the exe program in taskbar/dock).

In fact, when restarting Playonlinux, it says that Wine is not installed, although inside the program itself I have installed three versions as seen in the image above. But a separate system-wide installation of Wine is needed I think, as it is the case when Playonlinux is installed from Synaptic etc. That separate installation of Wine is not present.

Stuck again.

  • Just noticed that your question is a duplicate of another one at stackexchange. I see you found it too. DId this work?
    – lf_araujo
    Commented Dec 1, 2015 at 7:20
  • @Luís - I am the OP of both questions. I state above that something is different: the output of the same commands is different now (" trying the available options to replicate the solution of my older answer (see link above) I get to a point where too much of the whole system is bound to be removed")
    – user170
    Commented Dec 1, 2015 at 8:19
  • 1
    @cipricus , it seems to me like a conflict with with PPA's packages and most concerned one is ricotz's ppa for the edge x org drivers. to reproduce a similar case on a vm fresh install , add ricotz's ppa and update packages from it, then try install wine after that from ppa/or official repo. This case quiet similar to askubuntu.com/a/700497/26246
    – user.dz
    Commented Dec 3, 2015 at 13:43
  • 1
    I'm voting to close this question as off-topic because the OP solved the problem by reinstalling the OS, so this is unlikely to be useful to future users.
    – RolandiXor
    Commented Dec 9, 2015 at 13:21
  • 1
    @RolandiXor - I am voting this question for reopening because the problem appeared for me again in eOS (so that it might be useful to other eOS users) and this time I have found a solution that I want to share here: unix.stackexchange.com/a/214863/32012. I realize this looks like a cross-posting but it documents two separate occurrences of the same problem that was solved once by reinstalling the system and then by using aptitude.
    – user170
    Commented Feb 23, 2016 at 10:41

2 Answers 2


I've got this problem before and, unfortunately, I couldn't solve it without adding a ppa. Please note that you have limited slots to ppas, so use it only when you really need it. If you can avoid it, please do so.

Also, keep an updated backup of your system, because packages cannot be checked for security loopholes.

I would also strongly advise you to install TimeShift and do a system snapshot so you can roll back if none of this works (that would also return the status of your slots for ppas/gnu keys).

Just to make sure, try to install playonlinux deb directly, by issuing:

sudo dpkg -i PlayOnLinux_4.2.9.deb

If that is not enough you can try installing the whole PlayOnLinux ppa, by running:

wget -q "http://deb.playonlinux.com/public.gpg" -O- | sudo apt-key add -
sudo wget http://deb.playonlinux.com/playonlinux_trusty.list -O /etc/apt/sources.list.d/playonlinux.list
sudo apt-get update
sudo apt-get install 
  • Ok, great, now what I think is that you solved the initial question of installing playonlinux. It would be easy if you close this question, accept the answer and open a new question about running a specific .exe file in playonlinux. Now it seems that the problem is the particular .exe you are trying to install. What software are you trying to install?
    – lf_araujo
    Commented Dec 1, 2015 at 8:54
  • @cipricus I understand. I think that the proper behaviour in the past was also installing wine in the system level, but that is not the current behaviour of playonlinux. However, when I use playonlinux in my system I can pick the local wine version to run the specific wine version in the virtual drive. Another thing, for your information, last time I got playonlinux running on a eOS machine it kept warning me about the absence of system-wide wine. OK, let me ask you, can you install any other executable? Pick the latest version of wine, when prompted.
    – lf_araujo
    Commented Dec 1, 2015 at 9:19
  • I am not running it now, but I can confirm I did that in elementary inclusive. However, I would suggest you to install wine with their stable ppa. Run: $ sudo add-apt-repository ppa:ubuntu-wine/ppa $ sudo apt-get update $ sudo apt-get install wine.
    – lf_araujo
    Commented Dec 1, 2015 at 9:34
  • 1
    I am out of ideas. Please have a look at this discussion as well: askubuntu.com/questions/697648/…
    – lf_araujo
    Commented Dec 1, 2015 at 9:42
  • I have reinstalled eOS and was very careful to what I installed before trying to install Playonlinux. It worked fine, see my answer. I am positive Playonlinux installs Wine at system level: no doubt possible on that. I'm also 99% sure Playonlinux needs Wine at system level to work at all. I have voted to close the question as impossible to replicate and deleted my previous comments hereunder.
    – user170
    Commented Dec 2, 2015 at 13:32

The main idea is to use aptitude and its larger options.

The answer follows this one on ubuntuforums.

  • Made /etc/apt/sources.list support multiarch by adding [arch=amd64,i386] to the deb-line:

deb [arch=amd64,i386] http://fr.archive.ubuntu.com/ubuntu/ trusty universe

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo dpkg --add-architecture i386
sudo apt-get update

Update of the database now showed separate amd64 and i386 repos to be loaded.

Next I switched to aptitude, because of the more sophisticated dependency-solver:

sudo apt-get install aptitude

sudo aptitude --full-resolver -f install wine1.7

Full details: http://pastebin.com/Z9Ww11SU

What I did in short:

  • aptitude suggested a solution where wine1.7 would not be installed, that was selected first (20)
  • This solution was rejected with r 20 -- it was a bit complicated for me, I just replicated the commands from the other answer: first selected 20 instead of YES or NO; then r 20 (rejecting the removal of Wine 1.7);
  • then n (It seems that unless you choose Y, YES, aptitude --full-resolver gives you new options after each decision; I guess in this case was NO because it said "dependencies unresolved" for Wine);
  • the next step provided the good solution: to install Wine and to downgrade 14 packages:

ibasn1-8-heimdal libgphoto2-6 libgphoto2-port10 libgssapi3-heimdal libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libkrb5-26-heimdal liblcms2-2 libroken18-heimdal libsane libsane-common libwind0-heimdal

  • So, last one was Y YES, and Wine 1.7 was installed.

  • After that, the installation of playonlinux went without problems:

The following NEW packages will be installed:
  libwxgtk-media2.8-0{a} mesa-utils{a} playonlinux python-wxgtk2.8{a} python-wxversion{a} 
0 packages upgraded, 5 newly installed, 0 to remove and 0 not upgraded.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.