0

I have an existing Windows 10 installation and a free partition with 600 GB in which I would like to install Elementary.

I have created a USB ISO for Elemetary OS Juno. I firstly used Rufus, but I have also tried with Universal USB Installer.

I have set nomodeset in GRUB and also acpi=off and the combination of both. No matter what I do, no matter what pen drive I use... installation always freezes, and it happens either in the "Updates and other software" window when I click continue or after choosing "Some other", which leads me to a window in which it tries to show me the partition table (which never shows up).

I don't know what to do, I have tried everything I've seen, and the laptop is an Asus from past year with Intel Core i7 and NVIDIA GeForce. If I boot from the USB, no problem, but if I try to install, it always freezes.

I understand that I might be having problems with NVIDIA drivers (for what I have read), but I also understand that using nomodeset and acpi=off should skip the problem. BTW, when I set acpi=off, I got a black screen and the installation doesn't even start.

Any other suggestions?

0

In my case, the problem was that the system was constantly giving "PCI bus error". I caught that when I hit the power button to restart. I googled the error and arrived to this answer, whose solution worked for me: PCI bus error severity corrected

Just set pci=nomsi in GRUB and I could install seamlessly.

0

on my case, i can't even try Juno, I got a black screen for 3 seconds and my laptop reboot.. I tried with different kernel parameter nomodeset, nouveau.modeset=0, acpi=off i915.modeset=0, same issue

system config : i7 6700HQ, nvidia GTX950m, Samsung SM951 128GB M.2 PCI-e ACHI SSD

I stuck with Loki until I can fix the issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.