I have a Microsoft Surface Laptop 3. I tried to boot up elementary on a USB stick but it just goes blank after grub. Here are the things I tried:

  • disabled secure boot
  • tried nomodeset acpi=off kernel parameters
  • removed the quiet and splash kernel parameters

Nothing works. After pressing enter in grub the screen goes blank and is stuck. Even with the quiet parameter removed it shows nothing.

Any thoughts?


2 Answers 2


If you press ESC on boot (where the logo appears), you should be able to see the debug messages of boot process.

  • Didn't work. I don't get the boot logo. It is blank after grub. And like I mentioned removing the quiet from the kernel parameters usually shows the debug messages.
    – satran
    Jan 8, 2020 at 19:12

It looks like support for the Microsoft Surface Laptop 3 has yet to be mainlined. However, there appears to be support for it from the linux-surface project. You can find a dedicated page on your device here. I'm thinking you might be able to get your current installation working by using a chroot from the installer and installing the linux-surface kernel according to their instructions. Debian's RescueLive Wiki page has a great guide on how to chroot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.