0

Absolute beginner for everything regarding Linux here. I wanted to try it on an old laptop to see if I liked it before putting it on my actual computer but I had some issues.

I tried to install Elementary several times on my computer but it does not seem to work. When I reboot my pc, it launch, but from the USB drive, not from the computer. Here's what I did:

  • I formatted the computer, so Windows was basically a clean slate of nothing.
  • I set up my USB drive using Rufus and dowloading Elementary from the original website.
  • I went into the BiOs to change the order and put the USB as the primary source to boot.
  • Computer turn on, I installed Elementary, told me that the changes would not be taken into account until I reset the computer, so I did...
  • ... but when it turns on again, it boots from the USB drive. I tried turning it off and on again without the USB drive and it told me there was no BiOs on the computer, which make sense since I deleted windows when I first install Elementary (on purpose, I just want Linux on that computer).
  • I tried to reinstall it, and to take off the USB before rebooting, but it displayed a black screen with a lot of error.

So. Not sure what I can do from now on. It works with the USB I guess, but I did not try to install anything so I'm not sure if it will keep any change I make if I turn it off?

0

Basically, the first time you installed and didn't removed USB Drive due to which it booted again from USB Drive as the Boot Order was set. The second time you removed USB Drive earlier while it was in use hence it caused to display a lot of errors on the screen.

Please follow the following steps in order to get you system running:

  1. Make USB Drive Bootable using Rufus and Elementary OS' ISO.
  2. Restart the system and set boot order from BIOS to boot it from USB Drive
  3. Restart the computer to boot from USB Drive
  4. Install Elementary OS Juno
  5. When it tells you to restart, DO NOT unplug the USB. Just restart and go to BIOS again before it boots from USB again.
  6. Reset the Boot Order to boot from Hard Disk first.
  7. Save Settings and restart You are good to go.
  • Hello, thanks for your time and your answer. I followed your instruction to the letter, however, I still have the same issue. I install Elementary, I reset, and either I'm back at the black screen offering to launch a demo version or to install Elementary (If the USB is still on, even if Hard Drive is the first in the list in the BiOs) or, if I take out the USB once the laptop is off, a screen saying "no bootable device". Not sure what more I could do now. Thanks again for your time! – Coralie Jul 9 at 14:43
  • are you partitioning hard drive manually? and when it asks for installing bootloading at the end are you selecting correct device (Hard Drive ) ? – cstayyab Jul 9 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.