1

I've just got a new Dell XPS 15 (9650) with Windows 10 on it, but I want to install ElementaryOS (https://elementary.io) as the only OS (so I want to remove Windows). I created a bootable USB with Rufus and set is as default boot option in the BIOS.

The screen that i get is this:

enter image description here If I choose the option "Install elementary OS" I get a new screen with the E logo and nothing else. I've search this problem on the internet and I found out that it is related to the UEFI, so I found this article on Dell website (http://www.dell.com/support/article/it/it/itbsdt1/sln297060/xps-13-9343--how-to-install-ubuntu-developer-edition-1404-on-a-dell-pc-configured-for-the-unified-extensible-firmware-interface--uefi--bios?lang=en) that explains step by step what you need to do in order to install Ubuntu on the PC, but nothing.

I tried to remove the secure boot, to switch from "RAID on" to "AHCI" in the Sata Operation panel of the bios, uncheck "Enable Legacy Option ROMs" in the Advanced Boot Options panel, and create a new option in the boot sequence with grubx64.efi as the filename (tried also with BOOTx64.efi, but nothing).

All I get is the same screen with the E logo.

This is my current configuration (after lots of tries) of the BIOS:

Boot Sequence:

  1. My USB key with Elementary
  2. The boot option I created with "\EFI\BOOT\BOOTx64.EFI" as the file name
  3. Windows disk

Advanced Boot Options:

  1. Enable Legacy Option ROMs unchecked
  2. Enable Attempt Legacy Boot unchecked
  3. Enable UEFI Network Stack checked

UEFI Boot Path Security: "Always, Except Internal HDD" (possible other values: "Always" and "Never")

Sata Operation: "RAID On" (possible other values: "Disabled" and "AHCI")

Secure Boot: Enabled Fastboot: "Auto" (possible other values: "Minimal" and "Thorough")

My BIOS version is 1.5 I've read that you can start the OS installation with a nomodeset parameter, but it seems like it's not the proper solution.

Please, if you know, tell me what I need to change. Thank you very much

  • i have same probleme what is solution please ? – Redha Chemali Nov 8 '17 at 19:45
0

I have a Dell laptop as well (Inspiron) and I have two suggestions. First try the "try" elementary option to see if you can get into the OS, then install once you are in. Second, I had to disable UEFI and secure boot and enable Legacy boot.

  • Unfortunately that doesn't work... the "try" option gives me the same result, while by enabling the legacy boot (I already have UEFI and secure boot disabled), it does not even ask me if I want to try the OS or install it directly, and I get the usual screen with the logo – Mattia Costamagna Nov 4 '17 at 21:12
0

I ended up launching the OS installation with nomodeset as a parameter. After installing it I couldn't reboot/shutdown the pc, so I edited the grub file (sudo nano /etc/default/grub) and changed the GRUB_CMDLINE_LINUX_DEFAULT value to nomodeset. Now it works nicely.

  • The "nomodeset" allows me to begin elementaryos but then does not scale on Dell XPS 15 (4K). Is there a solution to this? – Viv Nov 8 '17 at 19:07
  • 1
    I think this is a partial solution, it enables you to install the graphics drivers you need. Then you shouldn't need nomodeset anymore. – Peter Uithoven Nov 9 '17 at 16:38
  • I know it's not the best solution... Tonight I'll try the solution suggested by George Barbaz, which seems the most accurate, and if that works I'll change the accepted answer to his. – Mattia Costamagna Nov 9 '17 at 16:49
0

damn ... my exact environment ... and i cannot remember how i got it working ... putting this here so I have a placeholder for when i get my BIOS configuration

I remember that the hardest parts was getting it to boot correctly and getting the docking station with two additional monitors set up ... checking

  • adding new answer for my values – George Barbaz Nov 7 '17 at 20:46
0

running Loki in same machine see if this helps

BIOS setting Boot Order Diskette, USB Storage, CD/DVD, NIC, M.2 PCIe SSD

Boot options LEGACY not UEFI

Adv boot options Enable Legacy boot ROMs

SATA RAID on

Then after booting

installed Intel Microcode and NVidea-384

for grub ... I am NOT running nomodeset ... that normally seems to work when you are having issues with monitors but I did take quiet out

Just from memory ... i think I remember that there was an issue with the M.2 PCIe SSD ... but cannot remember where i read it

I know ... I should have taken notes ... sue me ... I am the only non windows user here at work and I needed to get it working ASAP

  • I've read a lot of threads that say that for linux you should select AHCI instead of RAID on... Anoyhow I'll try to do what you suggested, since nomode set has been giving me a lot of problem – Mattia Costamagna Nov 9 '17 at 15:43
  • Unfortunately it keeps beeing stuck at the logo – Mattia Costamagna Nov 9 '17 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.