0

I have an HP laptop with Windows and Elementary OS Loki but when trying to install Hera it just keeps hanging in "Detecting filesystem". I had a similar issue installing Juno but only kept crashing while in the installation menu (gave up after several tries).

Basically I have a few partitions:

  • /home
  • / (Loki)
  • /swap
  • between 5 and 8 Windows' partitions (they were created automatically, I guess)

While installing, I keep the /home and /swap and choose Hera to install in the Loki partition. I proceed and after checking if the changes are ok it says this:

the installer needs to commit changes to partition tables, but cannot do so because partitions on the following mount points could not be unmounted:

/cdrom

Please close any applications using these mount points

Would you like the installer to try to unmount these partitions again?

I click continue and the "Detecting filesystem" window appears and in the details it says:

elementary ubiquity[3990]: Step_before = stepUserInfo
elementary systemd[1]: Starting Cleanup of Temporary Directories...
elementary systemd[1]: Started Cleanup of Temporary Directories.

After a few minutes it says:

elementary CRON [16065]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)

And it repeats the same thing every hour...

Tried with this but didn't work. Could anyone help?

Thanks in advance!

  • Is there a reason for not having passed your elementary OS Loki to Hera via a classic update sudo apt update && sudo apt upgrade && sudo apt dist-upgrade ? – LinkPhoenix Dec 15 '19 at 19:08
  • It doesn't update to Hera via classic update (just tried again), I think it only works from Juno. – covxy Dec 15 '19 at 19:21
0

I might be wrong, but I am almost sure that before I installed Juno I read somewhere that it was recommended to remove older versions of elementary before installing. I had no previous versions, so I didn't put all too much attention to it and went on with the parts pertinent to my installation. So the question would be: did you remove Loki beofre attempting to install Juno? Once you got Juno, Hera will come automatically, but apparently it's not the case with Loki-to-Juno upgrade.

|improve this answer|||||
  • Shouldn't that be the same as formatting the Loki partition to install Juno/Hera? How do I remove Loki from said partition before installing Hera? – covxy Dec 15 '19 at 20:28
  • Well, as I said I didn't have to do it, but I figure yes, formatting the partition should erase everything in it. If you formatted and still got error, then I would ask: did you try to install Hera directly? I think you should rather install Juno first, and then upgrade it using the AppCenter. After that you might want to read the thread about updating the kernel, which you do using the terminal. – Joy Dec 15 '19 at 21:05
  • I tried installing Juno before and just crashed during the installation menu. Tried it several times with the same result of everything freezing and not working. – covxy Dec 15 '19 at 21:13
  • the thread about updating the kernel is here: elementaryos.stackexchange.com/questions/21339/… – Joy Dec 15 '19 at 21:14
  • Did you check the sum, if it matches? Maybe you got a bad copy. Try downloading from another mirror. Did you use Rufus? Did you format both /home and / or just /? Don't forget to backup your data first! – Joy Dec 15 '19 at 21:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.