0

While inside the terminal I cannot press Ctrl+G. This is painful inside Emacs as it is the keybinding for cancelling a command. I believe it is bound to something else inside the terminal. How do I disable that or is it a bug?

2

I also ran into this problem as an emacs user.

Ctrl-G does work but it's assigned to something else. I checked the source code (https://github.com/elementary/terminal/blob/master/src/PantheonTerminalWindow.vala) and it turns out that Ctrl-G is used for ACTION_SEARCH_NEXT You can see this behaviour if you click the little magnifying glass button in terminal's title bar and enter a search term. Pressing ctrl-g will jump to the next hit of the search term.

As a quick and dirty fix, my plan is to disable the ACTION_SEARCH_NEXT keybinding (maybe just comment it out) and recompile locally. Though I believe a bug should be filed. In my opinion, ctrl-g should only be mapped to ACTION_SEARCH_NEXT when the search bar is active. By the way, this keybinding is used in other built apps such as Code and Epiphany.

Another work-around for now would be to install another terminal emulator. eg: xterm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.