When I set Emacs(terminal) as my default editor and try to open a file, I get the error message

 Failed to execute child process "xterm" (No such file or directory)

Additionally, when I try to click on the Emacs(terminal) application, nothing happens (presumably because of the same error).

I know I can fix this by installing xterm (sudo apt install xterm). Ideally, however, I'd prefer to use the pantheon-terminal to do this. How can I trigger the elementary terminal when opening terminal applications?

Note: I tried using the dconf editor. org > gnome > desktop > applications > terminal. But the value for exec, 'pantheon-terminal' seems like it should open the elementary terminal.

1 Answer 1


According to this post it should be:

io.elementary.terminal -e "emacs"

answer updated for Juno & Hera

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.