0

Just got a fresh copy of elementary after I messed it up.

Then again, I just installed zsh and I was configuring it, messed up the configuration. After that Oh well, lets remove and reinstall it. As I removed I realised that now I do not have a working terminal!

I tried the following
* When I do ctrl+Fn+F6, I'm directed to the original terminal but it asks for a login and when I do that it just redirects me to the same login command again.
* Tried Starting My Terminal. It is simply blinking. Nothing Happens in the terminal

Please help me fix my terminal again.

0

Luckily I had sublime text installed. Just traverse to \etc\ and then edit file named passwd.
It would require you to have admin access, but if you have replace all zsh references with bash.

I had to change only one line uname:x:1000:1000:user,,,:/home/uname:/bin/zsh to uname:x:1000:1000:user,,,:/home/uname:/bin/bash.

Hope this helps!

0

You can use the chsh utility change the login shell of a user in a terminal window.

chsh -s /bin/bash

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.