1

I have just installed Elementary OS. My WiFi is not working.

There are tons of solutions out there, and i have no idea which will work. Rather than trying all of them, it would be nice to have a solution.

Hardware:

    $ lshw -C network
WARNING: you should run this program as super-user.
  *-network               
       description: Ethernet interface
       product: 82579LM Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eno1
       version: 04
       serial: f0:1f:af:31:5f:e5
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.13-3 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:27 memory:f7e00000-f7e1ffff memory:f7e39000-f7e39fff ioport:f080(size=32)
  *-network
       description: Network controller
       product: BCM43228 802.11a/b/g/n
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: driver=bcma-pci-bridge latency=0
       resources: irq:17 memory:f7d00000-f7d03fff

I tried solutions in WiFi is not working on Loki

$ rfkill list all
1: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Even the following didn't work.

nmcli radio wifi on

Wifi did work during installation as it recognized my WiFi card (inside the laptop itself)

Many solutions suggest installing Backport. But I am not sure which one to install. A little help would be really beneficial.

It just doesn't work now.

  • 1
    Possible duplicate of WiFi is not working on Loki – Skywalker May 8 '18 at 8:19
  • @Skywalker I edited the question. I have already tried solutions in that particular thread. – Divyanshu Sharma May 8 '18 at 10:32
  • what if you cannot connect to the internet because the laptop does not have ethernet plug?? – sim Dec 2 '19 at 21:44
2

Ohk. I just found the solution for the problem above.

Go to AppCenter -> Updates and look into Drivers section. Install the software recommended there. That's it. It downloads and installs and WiFi starts working.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.