I just installed elementary OS 5.0 Juno on an Acer Aspire 5750Z; nothing else is on the hard drive.

During installation, a popup indicated some "WiFi networks available" and that I could connect one after reboot using Network Manager. When I attempt to do that I don't see the WiFi network that was listed in the popup, and I am unsuccessful at adding it, with or without an Ethernet connection.

Philip Jones

  • Is this your WiFi device? ->Atheros AR5B97 (hardwaresecrets.com/acer-aspire-5750-laptop/5). Could you run and output this: $ lspci -nnk | grep -iA2 net; dmesg | grep ath
    – Sebastian
    Commented Jan 2, 2019 at 3:37
  • Here's what I get; sorry about formatting. :~$ lspci -nnk | grep -iA2 net; dmesg | grep ath 02:00.0 Ethernet controller [0200]: Broadcom Limited NetLink BCM57785 Gigabit Ethernet PCIe [14e4:16b5] (rev 10) Subsystem: Acer Incorporated [ALI] NetLink BCM57785 Gigabit Ethernet PCIe [1025:0504] Kernel driveer in use: tg3 Kernel modules: tg3 03:00.0 Network controller [0280]: Broadcom Limited BCM43227 802.11b/g/n [14e4:4358 Subsystem: Foxconn International, Inc. BCM43227 802.11b/g/n [105b:e040] Kernel driver in use: bcma-pci-bridge Commented Jan 2, 2019 at 14:31
  • edit your own post, don't paste it here please
    – Sebastian
    Commented Jan 2, 2019 at 14:38
  • If it's solved, then mark the correct answer as accepted and if you solved by yourself, write it down and accept it. Bye
    – Sebastian
    Commented Jan 2, 2019 at 23:33
  • Please mark the answer that helped you solve the problem, you don't have to add anything to the title.
    – Hasan
    Commented Jan 3, 2019 at 14:29

2 Answers 2


I had the same problem after I couldn't recover from a Window's 10 bad config issue and decided to go Linux for my desktops. I even installed it three times thinking I did something wrong. Here's the fix that solved my problem...connect to a wired interface, open up a terminal and execute

sudo apt-get install bcmwl-kernel-source

Hope that helps

  • That seems to have done the trick; thanks very much. Commented Jan 2, 2019 at 22:46
  • Dude that was what I wrote in the first lines of the answer, I can't believe it. Anyway glad you solved it but remember that this system act as a library for future people with the same problem.
    – Sebastian
    Commented Jan 2, 2019 at 23:35

This is your WiFi adapter

Brand: Broadcom Limited
Model: BCM43227
PCI.ID: 14e4:4358

First, run (to start fresh)

$ sudo apt purge bcmwl-kernel-source

$ sudo apt install linux-headers-generic dkms bcmwl-kernel-source

$ sudo modprobe wl


If it doesn't work continue...

From https://askubuntu.com/questions/55868/installing-broadcom-wireless-drivers

In some computers, before performing the commands, you will need to deactivate the Secure Boot Options in your BIOS. This applies for cases, for example, where the bcmwl-kernel-source is already installed but the driver does not yet work. You can do a reinstall like so, or disable Secure Boot by going to your BIOS Setup:

After you disable Secure Boot, reinstall

$ sudo apt install --reinstall bcmwl-kernel-source

$ sudo modprobe wl

If nothing above works then we have to check the modules

Just run

$ lsmod
$ grep -i blacklist /etc/modprobe.d/blacklist.conf:
$ cat /etc/modules
$ ls /etc/modprobe.d

and paste the output editing your original question please, with that info I can tell you what command to run to blacklist some modules who are in conflict

If brcmsmac and bcma are loaded, then...


$ printf "# BCM43227 doesn't get detected\nblacklist brcmsmac\nblacklist bcma\n" | sudo tee -a /etc/modprobe.d/blacklist.conf

Edit /etc/modules (I'll use the text editor nano)

$ sudo nano /etc/modules

And remove brcmsmac and bcma from /etc/modules

Also if you don't have wl in /etc/modules, just add it in a new line and save the file


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.