11

I have just installed elementary OS Loki and it looks great. I have one problem though. WiFi is not working. During installation it worked perfectly and I was able to connect to my home network and check on the boxes for download updates & third party software. Now my laptop WiFi button's LED is yellow instead of white and it says WiFi is disabled. What should I do?

  • So I reinstalled without connecting during this process. It keeps my driver and WiFi works just fine. But then I type sudo apt get update and I restart. Now WiFi is not working again. So I guess there are 2 drivers and after update it uses the 2nd one which is not working. I can t understand since I used Ubuntu a lot from 14.04 to 16.04 and I had no problems. What is wrong with elementary os? – Andrei Sep 12 '16 at 12:08
  • 2
    Without information about your hardware, it is impossible for anyone to help you. – Gabriel Sep 12 '16 at 17:43
  • so basically I've got a RT3290 network adapter, tried installing a driver from different websites with different methodes, had no luck. But it's quite odd that with Ubuntu 16.04 it works just fine ( isn't Loki based on Ubuntu? ) And main point is that after install WiFi worked just fine, but I had no apps in AppCenter others than default ones, so I typed get update in a terminal then restarted and poof, full of apps in AppCenter but Wifi isn't working anymore ( connected with a cable ethernet ). Any thoughts? Cheers! – andreisdd Sep 13 '16 at 18:40
  • Have you tried filing a bug report? bugs.launchpad.net/elementaryos/+bug – wolf Oct 3 '16 at 3:40
  • Possible duplicate of Ralink RT3290 Wi-Fi drivers missing after install – wolf Oct 9 '16 at 6:24
5

Try nmcli radio wifi on through terminal

  • This worked for me while rfkill didn't give proper output, was searching from long time. Using usb WiFi adaptor. – Techie May 25 '17 at 16:58
  • Glad it worked. – Sudarshan Kakoty May 27 '17 at 18:43
2

I also have some issues with wireless on Loki. What I did:

  1. Open the terminal/console and type:

    rfkill list all
    

    You should probably get a result like this:

    0: sony-wifi: Wireless LAN
            Soft blocked: yes
            Hard blocked: no
    1: sony-bluetooth: Bluetooth
            Soft blocked: no
            Hard blocked: no
    2: hci0: Bluetooth
            Soft blocked: no
            Hard blocked: no
    3: phy0: Wireless LAN
            Soft blocked: no
            Hard blocked: no
    4: nfc0: NFC
            Soft blocked: no
            Hard blocked: no
    

    So as you can see Wireless LAN has status: Soft blocked: yes

  2. Now run in the terminal the command:

    rfkill unblock 0 
    /* 
    * or another number which coresponde to your wi-fi (example: sony-wifi):
    * rfkill unblock <number>
    */
    
  3. If the wireless is still off try to reboot your PC and check if wireless is on. If not try again the first steps.
  • 1
    I have run the commend on my MacBook Pro (Retina, 13-inch, Early 2015) i found 0: bluetooth: Bluetooth Soft blocked: no Hard blocked: no only – user2129798 Sep 20 '16 at 19:32

protected by Community Feb 24 '17 at 4:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.