0

I just installed elementary on my Windows PC and I have problems with wireless network : the WIFI networks are not detected.

network settings You can see the wireless connexion is enabled, but it says it is disabled... The available networks are detected in ~the 5 first minutes of uptime, and then... nothing.

me@mypc:~$ ip a | grep wlp
3: wlp3s0:  mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 40:9f:38:55:af:09 brd ff:ff:ff:ff:ff:ff

Here you can see that wlp3s0 is "DOWN". Can you help me to use my wireless network ?

PS: My version of elementary is 5.0, and all packages are up-to-date. My PC is an ASUS Vivobook 14 X405UA

The command sudo lshw -sanitize -C network returns

 *-network                 
       description: Ethernet interface
       produit: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:02:00.0
       nom logique: enp2s0
       version: 15
       numéro de série: [REMOVED]
       taille: 1Gbit/s
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=[REMOVED] latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       ressources: irq:16 portE/S:e000(taille=256) mémoire:ef104000-ef104fff mémoire:ef100000-ef103fff
  *-generic
       description: Interface réseau sans fil
       produit: Illegal Vendor ID
       fabriquant: Illegal Vendor ID
       identifiant matériel: 0
       information bus: pci@0000:03:00.0
       nom logique: wlp3s0
       version: ff
       numéro de série: [REMOVED]
       bits: 32 bits
       horloge: 66MHz
       fonctionnalités: bus_master vga_palette cap_list ethernet physical wireless
       configuration: broadcast=yes driver=r8822be driverversion=4.15.0-43-generic firmware=N/A latency=255 link=no maxlatency=255 mingnt=255 multicast=yes wireless=IEEE 802.11
       ressources: irq:132 portE/S:d000(taille=256) mémoire:ef000000-ef00ffff

And lspci returns these informations about my wireless interface :

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device b822 (rev ff).

modinfo r8822be | grep parm returns

parm:           debug_level:int
parm:           swenc:Set to 1 for software crypto (default 0)
parm:           ips:Set to 0 to not use link power save (default 1)
parm:           swlps:Set to 1 to use SW control power save (default 0)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
parm:           msi:Set to 1 to use MSI interrupts mode (default 1)
parm:           dma64:Set to 1 to use DMA 64 (default 0)
parm:           aspm:Set to 1 to enable ASPM (default 1)
parm:           debug:Set debug level (0-5) (default 0)
parm:           debug_mask:Set debug mask (default 0) (ullong)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
.

  • Can you provide the machine brand and model, the wifi adapter brand and model if you know how to get it, and the output of the commands: sudo lshw -sanitize -C network | lspci – Sebastian Jan 1 at 21:59
  • Ok, I added them to my question. – Dxtower Jan 2 at 10:23
  • Run this please: modinfo r8822be | grep parm. And next time don't crop outputs, I got the info I needed but in the future don't do this. – Sebastian Jan 2 at 13:17
1

If one of the parameters is aspm, when you run $ modinfo r8822be | grep parm

Try, in a terminal window, running:

$ sudo modprobe -r r8822be

$ sudo modprobe r8822be aspm=0


If it works to make it permanent just run:

$ echo "options r8822be aspm=0" | sudo tee -a /etc/modprobe.d/50-r8822be.conf

The next time you reboot you won't have to execute any command

ref:

https://ubuntuforums.org/showthread.php?t=2364383&page=4&p=13748692#post13748692

https://askubuntu.com/a/1085786/890782

  • I tried your solution but when I ran this all wireless settings disappeared from the desktop. – Dxtower Jan 3 at 10:44
  • Yet you still "crop" the result by not providing them. I can't help you if you don't help me to help you. Simple as that. PS: To rollback just reboot, if you made the change permanent even if it didn't worked you clearly didn't read what I wrote. The solution for the later (in this specific case) is remove the file and reboot. To remove the file just run: sudo rm -fr /etc/modprobe.d/50-r8822be.conf. Good Luck – Sebastian Jan 3 at 16:31
  • Sorry, after testing your solution I forgot to post the output. I read your whole post and I did not make it persistent. I'll post the output tomorrow. – Dxtower Jan 3 at 23:00
  • I just added modinfo r8822be | grep parm output to my question – Dxtower Jan 4 at 10:48
  • Is my question abandoned ? I really need to use WiFi on eOS. – Dxtower Jan 11 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.